summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom X. Tobin2017-02-19 13:57:29 -0500
committerTom X. Tobin2017-02-19 13:57:29 -0500
commitd2bf346b88f5c5f4b8e18cf7e92dbff321ff78cd (patch)
treef5ceae0837498c7187af78ad7c3ac1324abaec3b
downloadaur-d2bf346b88f5c5f4b8e18cf7e92dbff321ff78cd.tar.gz
Initial commit of awless 0.0.13
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bea76eab8e6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = awless
+ pkgdesc = A command line interface for Amazon Web Services (AWS)
+ pkgver = 0.0.13
+ pkgrel = 1
+ url = https://github.com/wallix/awless
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ depends = glibc
+ source = https://github.com/wallix/awless/archive/0.0.13.tar.gz
+ sha256sums = c3fe8dcf826c6ecb3978012fe4905aa032978684bda516591e88dca954ad23bf
+
+pkgname = awless
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b633c30a360
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tom X. Tobin <tomxtobin@tomxtobin.com>
+
+pkgname=awless
+pkgver=0.0.13
+pkgrel=1
+pkgdesc="A command line interface for Amazon Web Services (AWS)"
+arch=('i686' 'x86_64')
+_vendor="github.com/wallix/${pkgname}"
+url="https://${_vendor}"
+license=('Apache')
+depends=('glibc')
+makedepends=('go')
+source=("https://${_vendor}/archive/${pkgver}.tar.gz")
+sha256sums=('c3fe8dcf826c6ecb3978012fe4905aa032978684bda516591e88dca954ad23bf')
+
+_vendorpath="gopath/src/$_vendor"
+
+prepare() {
+ mkdir -p $_vendorpath
+ mv -T $pkgname-$pkgver $_vendorpath
+}
+
+build() {
+ export GOPATH="$srcdir/gopath"
+ cd $_vendorpath
+ go build -o bin/$pkgname
+}
+
+package() {
+ cd $_vendorpath
+ install -Dm755 bin/$pkgname $pkgdir/usr/bin/$pkgname
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}