summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabxxbo2022-03-17 21:31:21 -0500
committerabxxbo2022-03-17 21:31:21 -0500
commit93568b14227028bee0daca33a30260bf4df34873 (patch)
tree9af2f6789b1c5449e1f58ab54a8ee691867a9d95
downloadaur-awm-git.tar.gz
Initial push.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c23547f31862
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = awm-git
+ pkgdesc = A floating window manager written with XCB.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/abxxbo/awm.git
+ arch = x86_64
+ arch = x86
+ license = GPL
+ makedepends = libxcb
+ makedepends = xcb-util
+ makedepends = xcb-util-keysyms
+ makedepends = xcb-util-wm
+ source = git+https://github.com/abxxbo/awm.git
+ md5sums = SKIP
+
+pkgname = awm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad643670c868
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: abxxbo <devavcado@gmail.com
+pkgname=awm-git
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="A floating window manager written with XCB."
+arch=(x86_64 x86)
+url="https://github.com/abxxbo/awm.git"
+license=('GPL')
+groups=()
+depends=()
+makedepends=(libxcb xcb-util xcb-util-keysyms xcb-util-wm)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd awm
+ make
+}
+
+package() {
+ cd awm
+ make DESTDIR="$pkgdir/" install
+}