summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2015-09-11 08:25:21 -0400
committerMario Finelli2015-09-11 08:25:21 -0400
commit9d6627951f55283b78b7080139a207eb02018701 (patch)
tree4a184bcc2fd64a180113c1d4961fa8e24ebffbfd
downloadaur-9d6627951f55283b78b7080139a207eb02018701.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
-rw-r--r--awoken-icons.install37
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbcb5f9ed931
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = awoken-icons
+ pkgdesc = Simple and quite complete icon set, Token-style.
+ pkgver = 2.5.2
+ pkgrel = 2
+ url = http://deviantart.com/view/163570862
+ install = awoken-icons.install
+ arch = any
+ license = CCPL:by-sa
+ depends = librsvg
+ optdepends = imagemagick: To color the iconset.
+ optdepends = zenity: To have a GUI for the configuration script.
+ optdepends = xdg-utils: To be able to launch programs from the configuration script.
+ options = !strip
+ source = awoken-icons.install
+ source = https://dl.dropboxusercontent.com/u/8029324/AwOken-2.5.zip
+ sha256sums = 846c254776cb4763afc9db13387ff306f77be3537730d76a26f005ab3f77b611
+ sha256sums = d122ee0457079aaa30a664ae582fbc6208414e8728f497dce399ed9f33f9b36e
+
+pkgname = awoken-icons
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c627dc299bc6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!awoken-icons.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91ea2ce6653c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Contributor: Alexander De Sousa <archaur.xandy21 at spamgourmet dot com>
+
+pkgname=awoken-icons
+pkgver=2.5.2
+pkgrel=2
+pkgdesc="Simple and quite complete icon set, Token-style."
+url="http://deviantart.com/view/163570862"
+arch=('any')
+license=('CCPL:by-sa')
+depends=('librsvg')
+optdepends=("imagemagick: To color the iconset."
+ "zenity: To have a GUI for the configuration script."
+ "xdg-utils: To be able to launch programs from the configuration script.")
+source=(awoken-icons.install
+ "https://dl.dropboxusercontent.com/u/8029324/AwOken-2.5.zip")
+options=('!strip')
+sha256sums=('846c254776cb4763afc9db13387ff306f77be3537730d76a26f005ab3f77b611'
+ 'd122ee0457079aaa30a664ae582fbc6208414e8728f497dce399ed9f33f9b36e')
+install=awoken-icons.install
+PKGEXT='.pkg.tar'
+
+package() {
+ install -dm755 "$pkgdir"/usr/{bin,share/icons}
+
+ msg2 "Copying files..."
+ for _theme in AwOken-2.5/AwOken{,Dark,White}.tar.gz; do
+ tar --no-same-owner -xzf $_theme -C "$pkgdir/usr/share/icons/"
+ done
+
+ msg2 "Adjusting permissions..."
+ find "$pkgdir/" -type d -exec chmod 755 '{}' \;
+ find "$pkgdir/" -type f -exec chmod 644 '{}' \;
+ find "$pkgdir/" -name awoken-icon-theme-customization\* -exec chmod 755 '{}' \;
+
+ # Symlink customization scripts in the user binaries directory:
+ ln -sf /usr/share/icons/AwOken/awoken-icon-theme-customization* "$pkgdir/usr/bin/"
+ ln -sf /usr/share/icons/AwOkenDark/awoken-icon-theme-customization-dark "$pkgdir/usr/bin/"
+ ln -sf /usr/share/icons/AwOkenWhite/awoken-icon-theme-customization-white "$pkgdir/usr/bin/"
+}
diff --git a/awoken-icons.install b/awoken-icons.install
new file mode 100644
index 000000000000..c8ed98105828
--- /dev/null
+++ b/awoken-icons.install
@@ -0,0 +1,37 @@
+post_install () {
+ echo "---- awoken-icons ---------------------------------------------------"
+ echo " This icon theme comes with a customization script to tune some"
+ echo " aspects of it such as folder or start here icons for example."
+ echo ""
+ echo " The customizations are performed for the user running the script,"
+ echo " so they wont afect other users."
+ echo ""
+ echo " To launch it simply run 'awoken-icon-theme-customization' from any"
+ echo " terminal and go through it."
+ echo "---------------------------------------------------------------------"
+}
+
+post_upgrade() {
+ echo "---- awoken-icons ---------------------------------------------------"
+ echo " If you ran the customization script previously you need to run it"
+ echo " again (and choose your preferences) in order to use the new version"
+ echo " of the icon set. If you wish to do a clean customization, remove"
+ echo " first your previous one by deleting:"
+ echo ""
+ echo " ~/.icons/{AwOken,AwOkenDark,AwOkenWhite}"
+ echo " and ~/{.AwOkenrc,.AwOkenrcDark,.AwOkenrcWhite}"
+ echo ""
+ echo " To customize it run 'awoken-icon-theme-customization'."
+ echo "---------------------------------------------------------------------"
+}
+
+post_remove() {
+ echo "---- awoken-icons ---------------------------------------------------"
+ echo " If you or any other user used the customization script that comes"
+ echo " with the icon set, to remove it completely there're 2 things that"
+ echo " need to be deleted manually in the home directory of those users:"
+ echo ""
+ echo " Configuration files: ~/{.AwOkenrc,.AwOkenrcDark,.AwOkenrcWhite}"
+ echo " And a copy of the icons: ~/.icons/{AwOken,AwOkenDark,AwOkenWhite}"
+ echo "---------------------------------------------------------------------"
+}