summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMjasnik2023-06-24 19:52:48 +0300
committerMjasnik2023-06-24 19:52:48 +0300
commit9643c762318dcddd8d41766302f0a86d4bf6494c (patch)
tree0a5165b52c8d47d42e0551afb91944656979f5c7
downloadaur-9643c762318dcddd8d41766302f0a86d4bf6494c.tar.gz
Initial AWOL package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42f9eeb34f29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = awol
+ pkgdesc = Anti-WOL (sleep / shutdown / restart on WOL) daemon
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/mjasnik/awol
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = asio
+ depends = systemd
+ provides = awol
+ conflicts = awol-git
+ source = awol::git+https://gitlab.com/mjasnik/awol
+ md5sums = SKIP
+
+pkgname = awol
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d2904df7c0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mjasnik
+
+_pkgname=awol
+pkgname=$_pkgname
+pkgver=0.1
+pkgrel=1
+pkgdesc="Anti-WOL (sleep / shutdown / restart on WOL) daemon"
+arch=('any')
+url='https://gitlab.com/mjasnik/awol'
+license=('GPL')
+depends=('systemd')
+makedepends=('git' 'asio')
+provides=('awol')
+conflicts=('awol-git')
+source=("$_pkgname::git+https://gitlab.com/mjasnik/awol")
+md5sums=('SKIP')
+
+build() {
+ cd "$_pkgname"
+ g++ -s -o awold awol.cpp
+}
+package() {
+ cd "$_pkgname"
+ install -m755 -d ${pkgdir}/usr/bin
+ install -m755 -d ${pkgdir}/lib/systemd/system
+ install -m755 -d ${pkgdir}/etc/awol
+ install -m644 awold.service ${pkgdir}/lib/systemd/system
+ install -m755 awold.conf "$pkgdir"/etc/awol
+ install -m755 awold "$pkgdir"/usr/bin
+}