summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2020-08-18 00:59:50 -0400
committerChris Severance2020-08-18 00:59:50 -0400
commit0967c52f8bcf61781ff9527845935f97d54bb33c (patch)
tree13cebf96f8d40097fa38be90dc4b0935bffad6fa
parent2f8318a56fb31ae46a1e4520cc78c090a2f60607 (diff)
downloadaur-0967c52f8bcf61781ff9527845935f97d54bb33c.tar.gz
Update to 3.18.2
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD14
2 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9ac21e62f2d..a1857ef06da9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,29 @@
# Generated by mksrcinfo v8
-# Mon Dec 23 19:49:19 UTC 2019
+# Tue Aug 18 04:59:50 UTC 2020
pkgbase = aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.17.0
+ pkgver = 3.18.2
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python
makedepends = python-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.17.0.tar.gz
- sha256sums = 0e6c3efde9676cc01087e9ffece851e5e271e21ce75182470bdbd2d78df0e191
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.18.2.tar.gz
+ sha256sums = 70c247f9d54b8071d7550127e665a42a837f72812c5a1749ddb17104fbdba8db
pkgname = aws-eb-cli
depends = python
- depends = python-botocore>1.13.0
- depends = python-botocore<1.14
+ depends = python-botocore>=1.15
+ depends = python-botocore<1.16
depends = python-cement=2.8.2
- depends = python-colorama>=0.3.9
- depends = python-colorama<0.4.0
+ depends = python-colorama>=0.4
+ depends = python-colorama<1.0
depends = python-future>=0.16.0
depends = python-future<0.17.0
depends = python-pathspec=0.5.9
depends = python-dateutil>=2.1
depends = python-dateutil<2.8.1
- depends = python-yaml>=3.10
- depends = python-yaml<=3.13
depends = python-requests>=2.20.1
depends = python-requests<2.21
depends = python-setuptools>=20.0
@@ -37,9 +35,13 @@ pkgname = aws-eb-cli
depends = python-urllib3<1.25
depends = python-wcwidth>=0.1.7
depends = python-wcwidth<0.2.0
- depends = docker-compose>=1.23.2
- depends = docker-compose<1.24.0
+ depends = python-yaml>=5.3.1
+ depends = python-yaml<5.4
+ depends = docker-compose>=1.25.2
+ depends = docker-compose<1.26.0
depends = python-blessed>=1.9.5
+ depends = python-docutils<0.16
+ depends = python-docutils>=0.10
depends = docker>=3.3.0
depends = python-requests>=2.14.2
conflicts = python2-aws-eb-cli
diff --git a/PKGBUILD b/PKGBUILD
index 0bc9dd7f776f..af6cced6b3ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybasend="${_pybase//-/}"
-pkgver='3.17.0'
+pkgver='3.18.2'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,7 @@ _verwatch=("https://pypi.org/simple/${_pybasend}/" "${_pybasend}-\([0-9\.]\+\)\.
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybasend: 0:1}/${_pybasend}/${_pybasend}-${pkgver}.tar.gz")
-sha256sums=('0e6c3efde9676cc01087e9ffece851e5e271e21ce75182470bdbd2d78df0e191')
+sha256sums=('70c247f9d54b8071d7550127e665a42a837f72812c5a1749ddb17104fbdba8db')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -44,13 +44,12 @@ _fn_pydepends() {
# Paste in from setup.py. This function does NOT work in zsh.
local _requires="
requires = [
- 'botocore>1.13.0,<1.14',
+ 'botocore>=1.15,<1.16',
'cement==2.8.2',
- 'colorama>=0.3.9,<0.4.0', # use the same range that 'docker-compose' uses
+ 'colorama>=0.4,<1.0', # use the same range that 'docker-compose' uses
'future>=0.16.0,<0.17.0',
'pathspec==0.5.9',
'python-dateutil>=2.1,<2.8.1', # use the same range that 'botocore' uses
- 'PyYAML>=3.10,<=3.13', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
'requests>=2.20.1,<2.21',
'setuptools >= 20.0',
'semantic_version == 2.5.0',
@@ -59,8 +58,11 @@ requires = [
'urllib3>=1.24.1,<1.25',
'wcwidth>=0.1.7,<0.2.0',
#found further down in setup.py
- 'docker-compose >= 1.23.2, < 1.24.0',
+ 'PyYAML>=5.3.1,<5.4', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
+ 'docker-compose >= 1.25.2, < 1.26.0',
'blessed>=1.9.5',
+ #Part of Botocore
+ 'docutils<0.16,>=0.10'
]
"
# Convert requires=[] to local _requires=()