summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2019-01-23 23:16:23 -0500
committerChris Severance2019-01-23 23:16:23 -0500
commit215a116f1c320314ae9478fde9a02c966455cf65 (patch)
tree57531ea178ad44682095e100c5ca6c93424f59c0
parentcde59a7978334b318b52f012a77e9d1f367a9cbe (diff)
downloadaur-215a116f1c320314ae9478fde9a02c966455cf65.tar.gz
Update to 3.14.10
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD23
2 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30465dfda7bc..b0716dd84085 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
# Generated by mksrcinfo v8
-# Fri Jan 18 03:03:19 UTC 2019
+# Thu Jan 24 04:16:23 UTC 2019
pkgbase = aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.14.9
+ pkgver = 3.14.10
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python
makedepends = python-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.14.9.tar.gz
- sha256sums = 0580093a0df8b02f4ce689932087e4bc1352a674d0137d48f0e6d1745734e5c6
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.14.10.tar.gz
+ sha256sums = cc2f32e4dc4c6ddea4033bf9de74cd520f5971249f3a3f5e5c48b7f867a89f6e
pkgname = aws-eb-cli
depends = python
- depends = python-botocore>=1.12.1
+ depends = python-botocore>=1.12.29
depends = python-botocore<1.13
depends = python-cement=2.8.2
depends = python-colorama>=0.3.9
@@ -24,16 +24,19 @@ pkgname = aws-eb-cli
depends = python-dateutil<3.0.0
depends = python-yaml>=3.10
depends = python-yaml<=3.13
+ depends = python-requests>=2.20.1
+ depends = python-requests<2.21
depends = python-setuptools>=20.0
depends = python-semantic_version=2.5.0
- depends = python-six=1.11.0
+ depends = python-six>=1.11.0
+ depends = python-six<1.12.0
depends = python-termcolor=1.1.0
- depends = python-urllib3>=1.21.1
- depends = python-urllib3<1.23
- depends = docker-compose>=1.21.2
- depends = docker-compose<1.22.0
+ depends = python-urllib3>=1.24.1
+ depends = python-urllib3<1.25
+ depends = docker-compose>=1.23.2
+ depends = docker-compose<1.24.0
depends = python-blessed>=1.9.5
depends = docker>=3.3.0
depends = python-requests>=2.14.2
- conflicts = python2-awsebcli
+ conflicts = python2-aws-eb-cli
diff --git a/PKGBUILD b/PKGBUILD
index 445a9902b149..353215e28da5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,21 +18,21 @@ else
pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
-_pybase="${_pybase//-/}"
-pkgver='3.14.9'
+_pybasend="${_pybase//-/}"
+pkgver='3.14.10'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
#url='http://aws.amazon.com/code/6752709412171743'
-url="https://pypi.python.org/pypi/${_pybase}"
+url="https://pypi.python.org/pypi/${_pybasend}"
license=('Apache') # Apache License 2.0
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
-_srcdir="${_pybase}-${pkgver}"
-_verwatch=("https://pypi.org/simple/${_pybase}/" "${_pybase}-\([0-9\.]\+\)\.tar\.gz" 't')
+_srcdir="${_pybasend}-${pkgver}"
+_verwatch=("https://pypi.org/simple/${_pybasend}/" "${_pybasend}-\([0-9\.]\+\)\.tar\.gz" 't')
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
-source=("https://files.pythonhosted.org/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
-sha256sums=('0580093a0df8b02f4ce689932087e4bc1352a674d0137d48f0e6d1745734e5c6')
+source=("https://files.pythonhosted.org/packages/source/${_pybasend: 0:1}/${_pybasend}/${_pybasend}-${pkgver}.tar.gz")
+sha256sums=('cc2f32e4dc4c6ddea4033bf9de74cd520f5971249f3a3f5e5c48b7f867a89f6e')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -44,19 +44,20 @@ _fn_pydepends() {
# Paste in from setup.py. This function does NOT work in zsh.
local _requires="
requires = [
- 'botocore>=1.12.1,<1.13',
+ 'botocore>=1.12.29,<1.13',
'cement==2.8.2',
'colorama>=0.3.9,<0.4.0', # use the same range that 'docker-compose' uses
'pathspec==0.5.5',
'python-dateutil>=2.1,<3.0.0', # use the same range that 'botocore' uses
'PyYAML>=3.10,<=3.13', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
+ 'requests>=2.20.1,<2.21',
'setuptools >= 20.0',
'semantic_version == 2.5.0',
- 'six == 1.11.0',
+ 'six>=1.11.0,<1.12.0',
'termcolor == 1.1.0',
- 'urllib3>=1.21.1,<1.23'
+ 'urllib3>=1.24.1,<1.25'
#found further down in setup.py
- 'docker-compose >= 1.21.2, < 1.22.0',
+ 'docker-compose >= 1.23.2, < 1.24.0',
'blessed>=1.9.5',
]
"