summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2017-02-23 11:32:03 -0500
committerChris Severance2017-02-23 11:32:03 -0500
commit327bc7dca54acffc042f751c28f19dfbfa79d8cb (patch)
treef22f443edbaf1e7e474630f364c829e5dffd1765
parent465bdcf4511b82bfeccc191ef86a7cb82ed67980 (diff)
downloadaur-327bc7dca54acffc042f751c28f19dfbfa79d8cb.tar.gz
Update to 3.10.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5254a5f0f044..42ec25db4fe4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Fri Feb 17 02:43:40 UTC 2017
+# Thu Feb 23 16:32:03 UTC 2017
pkgbase = aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.9.1
+ pkgver = 3.10.0
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python
makedepends = python-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.9.1.tar.gz
- sha256sums = cbcb086eb6e2ab54967db7c9137cd53d3a01ca999c10ef86f42e58d44381b14d
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.10.0.tar.gz
+ sha256sums = 4977ef3baf50784eb29987451a95c300e62b542b56516af9391035dc9a749b6a
pkgname = aws-eb-cli
depends = python
@@ -32,6 +32,7 @@ pkgname = aws-eb-cli
depends = python-dockerpty<=0.4.1
depends = python-semantic_version=2.5.0
depends = python-tabulate=0.7.5
+ depends = python-termcolor=1.1.0
depends = python-blessed=1.9.5
conflicts = python2-awsebcli
diff --git a/PKGBUILD b/PKGBUILD
index 23aedd468119..b9a90273562d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybase="${_pybase//-/}"
-pkgver='3.9.1'
+pkgver='3.10.0'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,7 @@ _verwatch=("https://pypi.python.org/simple/${_pybase}/" "${_pybase}-\([0-9\.]\+\
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
-sha256sums=('cbcb086eb6e2ab54967db7c9137cd53d3a01ca999c10ef86f42e58d44381b14d')
+sha256sums=('4977ef3baf50784eb29987451a95c300e62b542b56516af9391035dc9a749b6a')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -56,7 +56,8 @@ requires = ['pyyaml>=3.11',
'docker-py >= 1.1.0, <= 1.7.2',
'dockerpty >= 0.3.2, <= 0.4.1',
'semantic_version == 2.5.0',
- 'tabulate == 0.7.5'
+ 'tabulate == 0.7.5',
+ 'termcolor == 1.1.0',
#found further down in setup.py
'blessed==1.9.5',
]