summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-07-08 23:57:32 -0400
committerChris Severance2018-07-08 23:57:32 -0400
commit778f478192af236032b91a40f05389fc3bfbe209 (patch)
treef22e751f2d4af7797966ef02a21417cffb7af43f
parente635fe3363bc227890a0f99adcc20b276f67bf52 (diff)
downloadaur-778f478192af236032b91a40f05389fc3bfbe209.tar.gz
Update to 3.14.2
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD20
2 files changed, 24 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2bb0a4115b1..0fabfe8a3bc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,37 @@
# Generated by mksrcinfo v8
-# Sat May 26 16:27:22 UTC 2018
+# Mon Jul 9 03:57:32 UTC 2018
pkgbase = aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.13.0
+ pkgver = 3.14.2
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python
makedepends = python-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.13.0.tar.gz
- sha256sums = 5a74d44ea18e9b5cba2d2e22af9b100f2fa2c8e882eabdbf676a72e8a4eafc4a
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.14.2.tar.gz
+ sha256sums = 4880fdffed20b199bb71b1784cf3aefe81859b173ef0291a4c1a6ef08b96bb0c
pkgname = aws-eb-cli
depends = python
depends = python-botocore>=1.0.1
depends = python-cement=2.8.2
- depends = python-colorama=0.3.7
+ depends = python-colorama>=0.3.9
+ depends = python-colorama<0.4.0
depends = python-pathspec=0.5.5
- depends = python-yaml>=3.11
+ depends = python-dateutil>=2.1
+ depends = python-dateutil<3.0.0
+ depends = python-yaml>=3.10
+ depends = python-yaml<=3.12
depends = python-setuptools>=20.0
- depends = python-docker>=2.6.1
- depends = python-docker<2.7.0
- depends = python-dockerpty>=0.3.2
- depends = python-dockerpty<=0.4.1
- depends = python-docopt>=0.6.1
- depends = python-docopt<0.7
- depends = python-requests>=2.6.1
- depends = python-requests<=2.9.1
depends = python-semantic_version=2.5.0
depends = python-six=1.11.0
depends = python-tabulate=0.7.5
depends = python-termcolor=1.1.0
- depends = python-websocket-client>=0.11.0
- depends = python-websocket-client<1.0
+ depends = docker-compose>=1.21.2
+ depends = docker-compose<1.22.0
depends = python-blessed>=1.9.5
+ depends = docker>=3.3.0
+ depends = python-requests>=2.14.2
conflicts = python2-awsebcli
diff --git a/PKGBUILD b/PKGBUILD
index 62f975b2deef..54d7c41d5321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybase="${_pybase//-/}"
-pkgver='3.13.0'
+pkgver='3.14.2'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,7 @@ _verwatch=("https://pypi.org/simple/${_pybase}/" "${_pybase}-\([0-9\.]\+\)\.tar\
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
-sha256sums=('5a74d44ea18e9b5cba2d2e22af9b100f2fa2c8e882eabdbf676a72e8a4eafc4a')
+sha256sums=('4880fdffed20b199bb71b1784cf3aefe81859b173ef0291a4c1a6ef08b96bb0c')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -46,21 +46,17 @@ local _requires="
requires = [
'botocore>=1.0.1',
'cement==2.8.2',
- 'colorama==0.3.7',
+ 'colorama>=0.3.9,<0.4.0', # use the same range that 'docker-compose' uses
'pathspec==0.5.5',
- 'pyyaml>=3.11',
+ 'python-dateutil>=2.1,<3.0.0', # use the same range that 'botocore' uses
+ 'PyYAML>=3.10,<=3.12', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
'setuptools >= 20.0',
- ## For docker-compose
- 'docker >= 2.6.1, < 2.7.0',
- 'dockerpty >= 0.3.2, <= 0.4.1',
- 'docopt >= 0.6.1, < 0.7',
- 'requests >= 2.6.1, <= 2.9.1',
'semantic_version == 2.5.0',
'six == 1.11.0',
'tabulate == 0.7.5',
'termcolor == 1.1.0',
- 'websocket-client >= 0.11.0, < 1.0',
#found further down in setup.py
+ 'docker-compose >= 1.21.2, < 1.22.0',
'blessed>=1.9.5',
]
"
@@ -71,10 +67,12 @@ requires = [
_requires=("${_requires[@]// /}") # embedded spaces
_requires=("${_requires[@]%,}") # trailing commas
_requires=("${_requires[@]//==/$3}") # translate ==
+ _requires=("${_requires[@]#python-}") # remove leading python-
local _pynoless=" $2 " # we can search for ' foo '
_pydepends=()
local _pyst1
for _pyst1 in "${_requires[@]}"; do # foo>=0.0,<=0.0
+ _pyst1="${_pyst1,,}"
local _pyname="${_pyst1%%[<=>]*}" # foo
_pyst1="${_pyst1#${_pyname}}" # >=0.0,<=0.0
local IFS=','
@@ -94,6 +92,8 @@ _fn_pydepends "${_pyver}-" '' '='
#_pydepends=("${_pydepends[@]//-cement=2.4/-cement=2.4.0}")
#Arch drops the py prefix on pyyaml
_pydepends=("${_pydepends[@]//-pyyaml/-yaml}")
+_pydepends=("${_pydepends[@]//python-docker-compose/docker-compose}")
+_pydepends+=('docker>=3.3.0' "${_pyver}-requests>=2.14.2")
unset -f _fn_pydepends
build() {