summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2019-03-01 21:41:36 -0500
committerChris Severance2019-03-01 21:41:36 -0500
commitabc560bad8d41451b4b66cd14abdf46ed47f8fa2 (patch)
tree2a1b50e146d80926f7ee2b5d59b65f669d7ed311
parent215a116f1c320314ae9478fde9a02c966455cf65 (diff)
downloadaur-abc560bad8d41451b4b66cd14abdf46ed47f8fa2.tar.gz
autu: Update to 3.14.13-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0716dd84085..a249e26bfc45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Thu Jan 24 04:16:23 UTC 2019
+# Sat Mar 2 02:41:35 UTC 2019
pkgbase = aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.14.10
+ pkgver = 3.14.13
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python
makedepends = python-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.14.10.tar.gz
- sha256sums = cc2f32e4dc4c6ddea4033bf9de74cd520f5971249f3a3f5e5c48b7f867a89f6e
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.14.13.tar.gz
+ sha256sums = bd0d3b1a69cef2ed991cf89b440c1351b0fb4fa0196d669a7cc516daa6d58a7d
pkgname = aws-eb-cli
depends = python
@@ -19,7 +19,9 @@ pkgname = aws-eb-cli
depends = python-cement=2.8.2
depends = python-colorama>=0.3.9
depends = python-colorama<0.4.0
- depends = python-pathspec=0.5.5
+ depends = python-future>=0.16.0
+ depends = python-future<0.17.0
+ depends = python-pathspec=0.5.9
depends = python-dateutil>=2.1
depends = python-dateutil<3.0.0
depends = python-yaml>=3.10
@@ -33,6 +35,8 @@ pkgname = aws-eb-cli
depends = python-termcolor=1.1.0
depends = python-urllib3>=1.24.1
depends = python-urllib3<1.25
+ depends = python-wcwidth>=0.1.7
+ depends = python-wcwidth<0.2.0
depends = docker-compose>=1.23.2
depends = docker-compose<1.24.0
depends = python-blessed>=1.9.5
diff --git a/PKGBUILD b/PKGBUILD
index 353215e28da5..66c3d4491787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybasend="${_pybase//-/}"
-pkgver='3.14.10'
+pkgver='3.14.13'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,7 @@ _verwatch=("https://pypi.org/simple/${_pybasend}/" "${_pybasend}-\([0-9\.]\+\)\.
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybasend: 0:1}/${_pybasend}/${_pybasend}-${pkgver}.tar.gz")
-sha256sums=('cc2f32e4dc4c6ddea4033bf9de74cd520f5971249f3a3f5e5c48b7f867a89f6e')
+sha256sums=('bd0d3b1a69cef2ed991cf89b440c1351b0fb4fa0196d669a7cc516daa6d58a7d')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -47,7 +47,8 @@ requires = [
'botocore>=1.12.29,<1.13',
'cement==2.8.2',
'colorama>=0.3.9,<0.4.0', # use the same range that 'docker-compose' uses
- 'pathspec==0.5.5',
+ 'future>=0.16.0,<0.17.0',
+ 'pathspec==0.5.9',
'python-dateutil>=2.1,<3.0.0', # use the same range that 'botocore' uses
'PyYAML>=3.10,<=3.13', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
'requests>=2.20.1,<2.21',
@@ -55,7 +56,8 @@ requires = [
'semantic_version == 2.5.0',
'six>=1.11.0,<1.12.0',
'termcolor == 1.1.0',
- 'urllib3>=1.24.1,<1.25'
+ 'urllib3>=1.24.1,<1.25',
+ 'wcwidth>=0.1.7,<0.2.0',
#found further down in setup.py
'docker-compose >= 1.23.2, < 1.24.0',
'blessed>=1.9.5',