summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-06-28 15:01:27 -0400
committerChris Severance2016-06-28 15:01:27 -0400
commitbedc2b90fcbde8b7d6f1ddef80cbe20c4dda409f (patch)
tree05d634017f8fb7f302fa9ddcc0d2cd6958843161
parent7d27d56f698140ea16cb9693c68e5e780e74f322 (diff)
downloadaur-bedc2b90fcbde8b7d6f1ddef80cbe20c4dda409f.tar.gz
Update to 3.7.7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89870855ad1c..dda117c8fa10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Apr 25 13:33:25 UTC 2016
+# Tue Jun 28 19:01:27 UTC 2016
pkgbase = aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.7.6
+ pkgver = 3.7.7
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python
makedepends = python-distribute
- source = https://pypi.python.org/packages/56/6c/bf15423bbc54b7fe8cfc9a718c7a18434a760156ee81276511200f24c4a2/awsebcli-3.7.6.tar.gz
- sha256sums = c8b7a15b1e6c45fea55e247ad62e8acb7a8e73b8e8aa0a19c346ba1da265e820
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.7.7.tar.gz
+ sha256sums = 23f0ada9644cea1d64260de6f185a8c5daa4e0b1db65821572d35c648f3778af
pkgname = aws-eb-cli
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 05cb6d7e421d..0345c4240936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,19 +19,20 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybase="${_pybase//-/}"
-pkgver='3.7.6'
+pkgver='3.7.7'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
#url='http://aws.amazon.com/code/6752709412171743'
-url="https://pypi.python.org/pypi/${_pybase//-/}"
+url="https://pypi.python.org/pypi/${_pybase}"
license=('Apache') # Apache License 2.0
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
_srcdir="${_pybase}-${pkgver}"
_verwatch=("https://pypi.python.org/simple/${_pybase}/" "${_pybase}-\([0-9\.]\+\)\.tar\.gz" 't')
-#source=("https://pypi.python.org/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
-source=("https://pypi.python.org/packages/56/6c/bf15423bbc54b7fe8cfc9a718c7a18434a760156ee81276511200f24c4a2/awsebcli-3.7.6.tar.gz")
-sha256sums=('c8b7a15b1e6c45fea55e247ad62e8acb7a8e73b8e8aa0a19c346ba1da265e820')
+# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
+# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
+source=("https://files.pythonhosted.org/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
+sha256sums=('23f0ada9644cea1d64260de6f185a8c5daa4e0b1db65821572d35c648f3778af')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-