summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-12-15 14:49:35 -0500
committerChris Severance2016-12-15 14:49:35 -0500
commitf3a7984aac3ce15f68ef1d735c8235623be32b0e (patch)
treeb089999c01169d444de9accf909377d759160c1a
parent6ca8ef1e74610096c5bf352a70b5d54451674c5d (diff)
downloadaur-f3a7984aac3ce15f68ef1d735c8235623be32b0e.tar.gz
Update to 3.8.8
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49b90dd82a5e..deb27e037aaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Sat Dec 3 06:08:02 UTC 2016
+# Thu Dec 15 19:48:32 UTC 2016
pkgbase = aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.8.5
+ pkgver = 3.8.8
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python
makedepends = python-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.8.5.tar.gz
- sha256sums = e58150bb249f0f90490365b5fd9366e091161a7bde18db0f0e669a47d582c21f
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.8.8.tar.gz
+ sha256sums = c10bb3a1144fcb56e7ff3150ac7e4a1bf2c147e4ef6f0fa05b2bb3e6799b21fa
pkgname = aws-eb-cli
depends = python
@@ -18,14 +18,12 @@ pkgname = aws-eb-cli
depends = python-botocore>=1.0.1
depends = python-cement=2.8.2
depends = python-colorama=0.3.7
- depends = python-pathspec=0.3.4
+ depends = python-pathspec=0.5.0
depends = python-setuptools>=20.0
depends = python-docopt>=0.6.1
depends = python-docopt<0.7
depends = python-requests>=2.6.1
depends = python-requests<=2.9.1
- depends = python-texttable>=0.8.1
- depends = python-texttable<0.9
depends = python-websocket-client>=0.11.0
depends = python-websocket-client<1.0
depends = python-docker-py>=1.1.0
@@ -33,6 +31,7 @@ pkgname = aws-eb-cli
depends = python-dockerpty>=0.3.2
depends = python-dockerpty<=0.4.1
depends = python-semantic_version=2.5.0
+ depends = python-tabulate=0.7.5
depends = python-blessed=1.9.5
conflicts = python2-awsebcli
diff --git a/PKGBUILD b/PKGBUILD
index ad47480e0acd..ac9c12e67f7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybase="${_pybase//-/}"
-pkgver='3.8.5'
+pkgver='3.8.8'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,7 @@ _verwatch=("https://pypi.python.org/simple/${_pybase}/" "${_pybase}-\([0-9\.]\+\
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
-sha256sums=('e58150bb249f0f90490365b5fd9366e091161a7bde18db0f0e669a47d582c21f')
+sha256sums=('c10bb3a1144fcb56e7ff3150ac7e4a1bf2c147e4ef6f0fa05b2bb3e6799b21fa')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -47,16 +47,16 @@ requires = ['pyyaml>=3.11',
'botocore>=1.0.1',
'cement==2.8.2',
'colorama==0.3.7',
- 'pathspec==0.3.4',
+ 'pathspec==0.5.0',
'setuptools >= 20.0',
## For docker-compose
'docopt >= 0.6.1, < 0.7',
'requests >= 2.6.1, <= 2.9.1',
- 'texttable >= 0.8.1, < 0.9',
'websocket-client >= 0.11.0, < 1.0',
'docker-py >= 1.1.0, <= 1.7.2',
'dockerpty >= 0.3.2, <= 0.4.1',
- 'semantic_version == 2.5.0'
+ 'semantic_version == 2.5.0',
+ 'tabulate == 0.7.5'
#found further down in setup.py
'blessed==1.9.5',
]