summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZacharias Knudsen2019-01-03 14:51:26 +0100
committerZacharias Knudsen2019-01-03 14:51:26 +0100
commit4df29af236d19943f5aaa6154c1c1136e806f2c3 (patch)
tree6101c7608169308dacc3f96c365d8b3b47ca0f1d
parent8d0e8e557f8055fa6bfb040bdcb06d431611efdb (diff)
downloadaur-4df29af236d19943f5aaa6154c1c1136e806f2c3.tar.gz
ENH: Use github binary instead
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd2cc79ec371..00440a289282 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = aws-iam-authenticator-bin
pkgdesc = A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster
- pkgver = 1.10.3
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/kubernetes-sigs/aws-iam-authenticator
arch = x86_64
license = Apache
provides = aws-iam-authenticator
- noextract = aws-iam-authenticator
- source = https://amazon-eks.s3-us-west-2.amazonaws.com/1.10.3/2018-07-26/bin/linux/amd64/aws-iam-authenticator
- sha256sums = 246f6d13b051bbfb12962edca074c8f67436930e84b2bec3a45a5d9242dc6f0c
+ noextract = heptio-authenticator-aws_0.3.0_linux_amd64
+ source = https://github.com/kubernetes-sigs/aws-iam-authenticator/releases/download/v0.3.0/heptio-authenticator-aws_0.3.0_linux_amd64
+ sha256sums = 4b8ecce88f4749338e361baf1fba9f8970efed0ac3f58cc40b4979bc0d86eb7b
pkgname = aws-iam-authenticator-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3ed102b015ab..4808cfa6f5dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Zacharias Knudsen <zachasme@gmail.com>
pkgname=aws-iam-authenticator-bin
-pkgver=1.10.3
+pkgver=0.3.0
pkgrel=1
pkgdesc="A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster"
arch=('x86_64')
url="https://github.com/kubernetes-sigs/aws-iam-authenticator"
license=('Apache')
provides=('aws-iam-authenticator')
-source=("https://amazon-eks.s3-us-west-2.amazonaws.com/${pkgver}/2018-07-26/bin/linux/amd64/aws-iam-authenticator")
-noextract=("aws-iam-authenticator")
-sha256sums=("246f6d13b051bbfb12962edca074c8f67436930e84b2bec3a45a5d9242dc6f0c")
+source=("https://github.com/kubernetes-sigs/aws-iam-authenticator/releases/download/v${pkgver}/heptio-authenticator-aws_${pkgver}_linux_amd64")
+noextract=("heptio-authenticator-aws_${pkgver}_linux_amd64")
+sha256sums=("4b8ecce88f4749338e361baf1fba9f8970efed0ac3f58cc40b4979bc0d86eb7b")
package() {
- install -Dm 755 "${srcdir}/aws-iam-authenticator" "${pkgdir}/usr/bin/aws-iam-authenticator"
+ install -Dm 755 "${srcdir}/heptio-authenticator-aws_${pkgver}_linux_amd64" "${pkgdir}/usr/bin/aws-iam-authenticator"
}