summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZacharias Knudsen2020-07-13 11:39:07 +0200
committerZacharias Knudsen2020-07-13 11:39:07 +0200
commit52d5bbcbc64dc628638486b36b5bfa74d6fbdf1b (patch)
tree18113e9c07b6d641ff577b47b1b6721a683f3d7e
parentb9b6cdf9ca6b449e37031e7f65879c54facb56a8 (diff)
downloadaur-52d5bbcbc64dc628638486b36b5bfa74d6fbdf1b.tar.gz
Bump to v0.5.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d421b7fdd875..58a0802612b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = aws-iam-authenticator-bin
pkgdesc = A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster
- pkgver = 0.5.0
+ pkgver = 0.5.1
pkgrel = 1
url = https://github.com/kubernetes-sigs/aws-iam-authenticator
arch = x86_64
license = Apache
provides = aws-iam-authenticator
- source = https://github.com/kubernetes-sigs/aws-iam-authenticator/releases/download/v0.5.0/aws-iam-authenticator_0.5.0_linux_amd64
- sha256sums = 4ccb4788d60ed76e3e6a161b56e1e7d91da1fcd82c98f935ca74c0c2fa81b7a6
+ source = https://github.com/kubernetes-sigs/aws-iam-authenticator/releases/download/v0.5.1/aws-iam-authenticator_0.5.1_linux_amd64
+ sha256sums = afb16f35071c977554f1097cbb84ca4f38f9ce42142c8a0612716ae66bb9fdb9
pkgname = aws-iam-authenticator-bin
diff --git a/PKGBUILD b/PKGBUILD
index cb814d3f49eb..9d29a4d5c348 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Zacharias Knudsen <zachasme@gmail.com>
pkgname=aws-iam-authenticator-bin
-pkgver=0.5.0
+pkgver=0.5.1
pkgrel=1
pkgdesc="A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster"
arch=('x86_64')
-url="https://github.com/kubernetes-sigs/aws-iam-authenticator"
+url="https://github.com/kubernetes-sigs/${pkgname%-bin}"
license=('Apache')
-provides=('aws-iam-authenticator')
-source=("https://github.com/kubernetes-sigs/aws-iam-authenticator/releases/download/v${pkgver}/aws-iam-authenticator_${pkgver}_linux_amd64")
-sha256sums=("4ccb4788d60ed76e3e6a161b56e1e7d91da1fcd82c98f935ca74c0c2fa81b7a6")
+provides=("${pkgname%-bin}")
+source=("https://github.com/kubernetes-sigs/${pkgname%-bin}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_linux_amd64")
+sha256sums=("afb16f35071c977554f1097cbb84ca4f38f9ce42142c8a0612716ae66bb9fdb9")
package() {
- install -Dm 755 "${srcdir}/aws-iam-authenticator_${pkgver}_linux_amd64" "${pkgdir}/usr/bin/aws-iam-authenticator"
+ install -Dm 755 "${srcdir}/${pkgname%-bin}_${pkgver}_linux_amd64" "${pkgdir}/usr/bin/${pkgname%-bin}"
}