summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZacharias Knudsen2021-01-04 09:42:48 +0100
committerZacharias Knudsen2021-01-04 09:42:48 +0100
commit77b572bb49e9ca9b3e5e6e347b537778b9384dc5 (patch)
tree5dec17551d2baf5b5f7749efd1b496a46f136ece
parent52d5bbcbc64dc628638486b36b5bfa74d6fbdf1b (diff)
downloadaur-77b572bb49e9ca9b3e5e6e347b537778b9384dc5.tar.gz
Update to v0.5.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58a0802612b5..b297eaabf127 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = aws-iam-authenticator-bin
pkgdesc = A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster
- pkgver = 0.5.1
+ pkgver = 0.5.2
pkgrel = 1
url = https://github.com/kubernetes-sigs/aws-iam-authenticator
arch = x86_64
license = Apache
provides = aws-iam-authenticator
- source = https://github.com/kubernetes-sigs/aws-iam-authenticator/releases/download/v0.5.1/aws-iam-authenticator_0.5.1_linux_amd64
- sha256sums = afb16f35071c977554f1097cbb84ca4f38f9ce42142c8a0612716ae66bb9fdb9
+ source = https://github.com/kubernetes-sigs/aws-iam-authenticator/releases/download/v0.5.2/aws-iam-authenticator_0.5.2_linux_amd64
+ sha256sums = 5bbe44ad7f6dd87a02e0b463a2aed9611836eb2f40d7fbe8c517460a4385621b
pkgname = aws-iam-authenticator-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9d29a4d5c348..3ffe400e5b60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Zacharias Knudsen <zachasme@gmail.com>
pkgname=aws-iam-authenticator-bin
-pkgver=0.5.1
+pkgver=0.5.2
pkgrel=1
pkgdesc="A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster"
arch=('x86_64')
@@ -9,8 +9,10 @@ url="https://github.com/kubernetes-sigs/${pkgname%-bin}"
license=('Apache')
provides=("${pkgname%-bin}")
source=("https://github.com/kubernetes-sigs/${pkgname%-bin}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_linux_amd64")
-sha256sums=("afb16f35071c977554f1097cbb84ca4f38f9ce42142c8a0612716ae66bb9fdb9")
+sha256sums=("5bbe44ad7f6dd87a02e0b463a2aed9611836eb2f40d7fbe8c517460a4385621b")
package() {
- install -Dm 755 "${srcdir}/${pkgname%-bin}_${pkgver}_linux_amd64" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -D --mode 755 \
+ "${srcdir}/${pkgname%-bin}_${pkgver}_linux_amd64" \
+ "${pkgdir}/usr/bin/${pkgname%-bin}"
}