summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZacharias Knudsen2018-11-16 12:40:19 +0100
committerZacharias Knudsen2018-11-16 12:40:19 +0100
commitf36859ba8fa293819386cf17e8c2b1001a7612cc (patch)
treee465fc9f33f5d1ea32706c2eb174315cb39b71bf
downloadaur-f36859ba8fa293819386cf17e8c2b1001a7612cc.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd2cc79ec371
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = aws-iam-authenticator-bin
+ pkgdesc = A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster
+ pkgver = 1.10.3
+ pkgrel = 1
+ url = https://github.com/kubernetes-sigs/aws-iam-authenticator
+ arch = x86_64
+ license = Apache
+ provides = aws-iam-authenticator
+ noextract = aws-iam-authenticator
+ source = https://amazon-eks.s3-us-west-2.amazonaws.com/1.10.3/2018-07-26/bin/linux/amd64/aws-iam-authenticator
+ sha256sums = 246f6d13b051bbfb12962edca074c8f67436930e84b2bec3a45a5d9242dc6f0c
+
+pkgname = aws-iam-authenticator-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31d27563afeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1595953e6c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Zacharias Knudsen <zachasme@gmail.com>
+
+pkgname=aws-iam-authenticator-bin
+pkgver=1.10.3
+pkgrel=1
+pkgdesc="A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster"
+arch=('x86_64')
+url="https://github.com/kubernetes-sigs/aws-iam-authenticator"
+license=('Apache')
+provides=('aws-iam-authenticator')
+source=("https://amazon-eks.s3-us-west-2.amazonaws.com/${pkgver}/2018-07-26/bin/linux/amd64/aws-iam-authenticator")
+noextract=("aws-iam-authenticator")
+sha256sums=("246f6d13b051bbfb12962edca074c8f67436930e84b2bec3a45a5d9242dc6f0c")
+
+package() {
+ install -Dm 755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}