summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-08-19 22:25:59 +0200
committerMichal Wojdyla2021-08-19 22:25:59 +0200
commit5597847d571838af481e10d3abb609a1c195c6b3 (patch)
treea59b41e539b545e3572c7c09406504f0f9804313
parentb520e5a0a357f212babbde3f999d9af6d54ea2a3 (diff)
downloadaur-5597847d571838af481e10d3abb609a1c195c6b3.tar.gz
update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
2 files changed, 17 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a926ab94d4c..7b291104a467 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = aws-iam-authenticator-git
pkgdesc = A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster
- pkgver = v0.4.0.r5.gc2d2884d
+ pkgver = v0.5.3.r16.g375e2c90
pkgrel = 1
url = https://github.com/kubernetes-sigs/aws-iam-authenticator
arch = x86_64
- arch = i686
- arch = arm
+ arch = aarch64
license = Apache
makedepends = go
- makedepends = git
- makedepends = dep
- options = !strip
+ provides = aws-iam-authenticator
+ conflicts = aws-iam-authenticator
source = git+https://github.com/kubernetes-sigs/aws-iam-authenticator.git
sha512sums = SKIP
pkgname = aws-iam-authenticator-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a5437b52a007..4c6cc478ba20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: Chris Snell <chris.snell@gmail.com>
+# Contributor: Chris Snell <chris.snell@gmail.com>
pkgname=aws-iam-authenticator-git
_pkgname=aws-iam-authenticator
-_githubpath=github.com/kubernetes-sigs/aws-iam-authenticator
-pkgver=v0.4.0.r5.gc2d2884d
+pkgver=v0.5.3.r16.g375e2c90
pkgrel=1
-pkgdesc="A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster"
-arch=('x86_64' 'i686' 'arm')
-url="https://github.com/kubernetes-sigs/aws-iam-authenticator"
-options=('!strip')
+pkgdesc='A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster'
+arch=('x86_64' 'aarch64')
+url='https://github.com/kubernetes-sigs/aws-iam-authenticator'
license=('Apache')
-makedepends=('go' 'git' 'dep')
+makedepends=('go')
+conflicts=('aws-iam-authenticator')
+provides=('aws-iam-authenticator')
source=('git+https://github.com/kubernetes-sigs/aws-iam-authenticator.git')
sha512sums=('SKIP')
@@ -23,21 +23,13 @@ pkgver() {
}
build() {
- mkdir -p ${srcdir}/src/$_githubpath
cd "$srcdir/$_pkgname"
- git --work-tree=${srcdir}/src/$_githubpath checkout -f master
- cd "$srcdir/src/$_githubpath"
- export GOPATH=${srcdir}
- echo "Fetching dependencies with dep... (this will take a while)"
- dep ensure
- cd cmd/aws-iam-authenticator
- go build
+ go build \
+ --trimpath \
+ --ldflags "-X main.version=$pkgver" \
+ ./cmd/aws-iam-authenticator
}
package() {
- cd "$srcdir/src/$_githubpath"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
- cd "cmd/$_pkgname"
- install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm 755 "$srcdir/$_pkgname/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
}
-