summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksel2021-02-16 11:58:42 +0100
committeraksel2021-02-16 11:58:42 +0100
commitd041b68c9baef6f07bd54d6e52e1a5882658830d (patch)
treea9021049f6b0017e500a5bffedb75addbc28841b
downloadaur-d041b68c9baef6f07bd54d6e52e1a5882658830d.tar.gz
aws-sam-cli-bin v1.18.1
As of v1.18.0, aws-sam-cli has a native Linux installer. This package lets you avoid the Python dependency hell. I like that! :)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2558afb7fb3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aws-sam-cli-bin
+ pkgdesc = CLI tool to build, test, debug, and deploy Serverless applications using AWS SAM
+ pkgver = 1.18.1
+ pkgrel = 1
+ url = https://github.com/awslabs/aws-sam-cli
+ arch = any
+ license = Apache
+ optdepends = docker
+ provides = aws-sam-cli
+ conflicts = aws-sam-cli
+ source = https://github.com/aws/aws-sam-cli/releases/download/v1.18.1/aws-sam-cli-linux-x86_64.zip
+ sha256sums = 742ea69de70100b132cd636612d5d256e628178f366284bf74defef656969968
+
+pkgname = aws-sam-cli-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1170f23e6d3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: aksel <aksel@akseltorgard.com>
+
+pkgname=aws-sam-cli-bin
+pkgver=1.18.1
+pkgrel=1
+pkgdesc='CLI tool to build, test, debug, and deploy Serverless applications using AWS SAM'
+arch=('any')
+url='https://github.com/awslabs/aws-sam-cli'
+license=('Apache')
+optdepends=('docker')
+source=("https://github.com/aws/aws-sam-cli/releases/download/v$pkgver/aws-sam-cli-linux-x86_64.zip")
+sha256sums=('742ea69de70100b132cd636612d5d256e628178f366284bf74defef656969968')
+provides=("aws-sam-cli")
+conflicts=("aws-sam-cli")
+
+package() {
+ cd "$srcdir"
+
+ ./install --install-dir "$pkgdir/usr/local/aws-sam-cli" --bin-dir "$pkgdir/usr/local/bin"
+}