summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Miller2017-08-12 03:11:29 -0700
committerAaron Miller2017-08-12 03:11:29 -0700
commit0fe172a5adc2b791838f239bda8d6871974d3fdd (patch)
tree9c945bcf08fdeb5681a1ee1cb345d2a721d92186
downloadaur-0fe172a5adc2b791838f239bda8d6871974d3fdd.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81f33b497d28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = aws-sam-local
+ pkgdesc = CLI tool for local development and testing of Serverless applications
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/awslabs/aws-sam-local
+ arch = x86_64
+ arch = i686
+ license = Apache
+ depends = docker
+ source_x86_64 = https://github.com/awslabs/aws-sam-local/releases/download/v{0.1.0}/sam_{0.1.0}_linux_amd64.tar.gz
+ sha256sums_x86_64 = 68dca0e5022a855bdab060b9d2729468c1f4aafa0a65f48050dacc5ae41073ce
+ source_i686 = https://github.com/awslabs/aws-sam-local/releases/download/v{0.1.0}/sam_{0.1.0}_linux_386.tar.gz
+ sha256sums_i686 = 4a52618a97eb2a28b22e18ee3f51d9c74c611339ee10bab84809433ee4a6911c
+
+pkgname = aws-sam-local
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f1b97e9733c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Aaron Miller <aaronm@cldtk.com>
+
+pkgname=aws-sam-local
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='CLI tool for local development and testing of Serverless applications'
+arch=('x86_64' 'i686')
+url='https://github.com/awslabs/aws-sam-local'
+license=('Apache')
+depends=('docker')
+source_i686=("https://github.com/awslabs/aws-sam-local/releases/download/v{$pkgver}/sam_{$pkgver}_linux_386.tar.gz")
+source_x86_64=("https://github.com/awslabs/aws-sam-local/releases/download/v{$pkgver}/sam_{$pkgver}_linux_amd64.tar.gz")
+sha256sums_i686=('4a52618a97eb2a28b22e18ee3f51d9c74c611339ee10bab84809433ee4a6911c')
+sha256sums_x86_64=('68dca0e5022a855bdab060b9d2729468c1f4aafa0a65f48050dacc5ae41073ce')
+
+package() {
+ install -Dm755 sam "${pkgdir}/usr/bin/sam"
+}