summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Callahan2022-11-28 12:10:33 +1100
committerJames Callahan2022-11-28 12:10:33 +1100
commitff7de920eb8a86a5096439b6000ca86ae37cf10a (patch)
tree0ec2101f6d738feb99cd6348080f1f5905dbc246
parent7c5ea64b72fda36e17dff82700f62b4a22e6b68e (diff)
downloadaur-ff7de920eb8a86a5096439b6000ca86ae37cf10a.tar.gz
Move go module download into prepare()
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdb715f79698..53b57f89dec8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,12 @@ makedepends=('go')
source=("$pkgname-v$pkgver::https://github.com/joshdk/aws-saml/archive/refs/tags/v$_releasever.tar.gz")
sha256sums=('f565ae76cd4b6d92128cb57d8ebc4085903ee72b90240c0867d4f1456f205367')
+prepare() {
+ cd "$pkgname-$_releasever"
+
+ go mod download
+}
+
build() {
cd "$pkgname-$_releasever"
@@ -17,6 +23,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
+ export GOPROXY=off
go build \
-trimpath \
-buildmode=pie \