summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-02-27 22:36:37 -0500
committerTony Lambiris2019-02-27 22:36:37 -0500
commit4376d3fce8d84e9d7ca1495414a46078564e5e38 (patch)
tree8ab408abdc11df3e791971c4a33c9d6cb8e75c21
parent97c086cea3e993196646393d106494574577c4c5 (diff)
downloadaur-4376d3fce8d84e9d7ca1495414a46078564e5e38.tar.gz
Version bump
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD21
3 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86a298133cba..4c8beb150879 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aws-sdk-cpp-git
pkgdesc = AWS SDK for C++
- pkgver = 1.7.33.r0.gc64f092956
+ pkgver = 1.7.59.r0.gcc21273299
pkgrel = 1
url = https://github.com/aws/aws-sdk-cpp
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = aws-sdk-cpp-git
makedepends = zlib
makedepends = libutil-linux
depends = cmake
- source = aws-sdk-cpp-git::git+https://github.com/aws/aws-sdk-cpp#commit=c18f2daa64d5968861bbb58a437fd06a9475e294
+ source = aws-sdk-cpp-git::git+https://github.com/aws/aws-sdk-cpp#commit=cc212732996dcabbf100404b9af773f85cfb1a42
sha256sums = SKIP
pkgname = aws-sdk-cpp-git
diff --git a/.gitignore b/.gitignore
index e95bab8bea32..d6a090073448 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ src
pkg
aws-sdk-cpp-git
*pkg.tar.xz
+tags
diff --git a/PKGBUILD b/PKGBUILD
index aa90dc660c2c..2d5382dc1227 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=aws-sdk-cpp-git
-pkgver=1.7.33.r0.gc64f092956
+pkgver=1.7.59.r0.gcc21273299
pkgrel=1
pkgdesc="AWS SDK for C++"
arch=('x86_64')
@@ -8,20 +8,24 @@ url="https://github.com/aws/aws-sdk-cpp"
license=('Apache')
depends=('cmake')
makedepends=('openssl' 'curl' 'zlib' 'libutil-linux')
-_gitcommit='c18f2daa64d5968861bbb58a437fd06a9475e294'
-source=("${pkgname}::git+https://github.com/aws/aws-sdk-cpp#commit=${_gitcommit}")
+conclits=('aws-checksums-git')
+_gitcommit='cc212732996dcabbf100404b9af773f85cfb1a42'
#source=("${pkgname}::git+https://github.com/aws/aws-sdk-cpp")
+source=("${pkgname}::git+https://github.com/aws/aws-sdk-cpp#commit=${_gitcommit}")
sha256sums=('SKIP')
# disable until aws engineers can settle on their fucking build process
#pkgver() {
-# cd ${pkgname}
+# cd "${srcdir}/${pkgname}"
#
# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
#}
build() {
- cd ${pkgname}
+ cd "${srcdir}/${pkgname}"
+
+ mkdir -p build
+ cd build
CMAKE_FLAGS="-Wno-dev \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
@@ -32,13 +36,14 @@ build() {
-DNO_HTTP_CLIENT=1 \
-DMINIMIZE_SIZE=ON \
-DBUILD_SHARED_LIBS=OFF"
- cmake $CMAKE_FLAGS .
+ cmake $CMAKE_FLAGS ..
make ${MAKEFLAGS}
}
package() {
- cd ${pkgname}
+ cd "${srcdir}/${pkgname}"
- make DESTDIR="${pkgdir}" install
+ make -C build DESTDIR="${pkgdir}" install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}