summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCallum2019-11-20 21:43:56 +0000
committerCallum2019-11-20 21:43:56 +0000
commitcd9e3704152d234180ab29b708e538088defeaf6 (patch)
tree338d78bf12bd9c52bbba6d2ac3ebb79d3957286d
parentc0521c37532ed35a9fb18849aca16ee700e84377 (diff)
downloadaur-cd9e3704152d234180ab29b708e538088defeaf6.tar.gz
feat: release 1.1.35.0-3
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
-rw-r--r--aws-session-manager-plugin.install57
3 files changed, 6 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6e0c22ff265..54984e7eac9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = aws-session-manager-plugin
pkgdesc = AWS Session Manager Plugin for aws-cli.
pkgver = 1.1.35.0
- pkgrel = 2
+ pkgrel = 3
url = https://docs.aws.amazon.com/systems-manager/latest/userguide/session-manager-working-with-install-plugin.html
- install = aws-session-manager-plugin.install
arch = i686
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 55293737aaaa..20129d718e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Callum Denby <me@callumdenby.com>
pkgname=aws-session-manager-plugin
pkgver=1.1.35.0
-pkgrel=2
+pkgrel=3
pkgdesc="AWS Session Manager Plugin for aws-cli."
arch=('i686' 'x86_64')
url="https://docs.aws.amazon.com/systems-manager/latest/userguide/session-manager-working-with-install-plugin.html"
@@ -11,7 +11,6 @@ license=('custom')
depends=('aws-cli')
backup=('usr/lib/systemd/system/session-manager-plugin.service' 'usr/sessionmanagerplugin/LICENSE' 'usr/sessionmanagerplugin/seelog.xml' 'usr/sessionmanagerplugin/VERSION')
options=('!strip' '!emptydirs')
-install=${pkgname}.install
source_i686=(https://s3.amazonaws.com/session-manager-downloads/plugin/${pkgver}/ubuntu_32bit/session-manager-plugin.deb)
source_x86_64=(https://s3.amazonaws.com/session-manager-downloads/plugin/${pkgver}/ubuntu_64bit/session-manager-plugin.deb)
sha512sums_i686=('025b900e3387e3885a7330bb2188ef9a1bd8a40bb16f16f5f246e849b5efb2d1ee4d4ecfb99287d87381ae030f2603ae1deeee18d88b4f7327e6ffc99579ef03')
@@ -25,14 +24,16 @@ package(){
# Fix directories structure differencies
cd "${pkgdir}"
+ mkdir -p usr/bin
mkdir -p usr/lib 2> /dev/null; mv lib/* usr/lib; rm -rf lib
- # rm -fr etc/init/
+ rm -fr etc/
sed -i 's/usr\/local/usr/' usr/lib/systemd/system/session-manager-plugin.service
mv usr/local/* usr; rm -rf usr/local
- cd ..
+ ln -sf /usr/sessionmanagerplugin/bin/session-manager-plugin usr/bin/session-manager-plugin
+ cd ..
}
diff --git a/aws-session-manager-plugin.install b/aws-session-manager-plugin.install
deleted file mode 100644
index 6d93a6275b8f..000000000000
--- a/aws-session-manager-plugin.install
+++ /dev/null
@@ -1,57 +0,0 @@
-pre_install() {
- echo "Preparing for install"
- if [ $(cat /proc/1/comm) = init ]
- then
- stop session-manager-plugin || true
- elif [ $(cat /proc/1/comm) = systemd ]
- then
- systemctl stop session-manager-plugin
- systemctl daemon-reload
- fi
-}
-
-post_install() {
- echo "Starting session-manager-plugin"
- if [ $(cat /proc/1/comm) = init ]
- then
- start session-manager-plugin || true
- elif [ $(cat /proc/1/comm) = systemd ]
- then
- systemctl enable session-manager-plugin
- systemctl start session-manager-plugin
- systemctl daemon-reload
- fi
- if [ -f /usr/bin/session-manager-plugin ]
- then
- rm /usr/bin/session-manager-plugin
- fi
- ln -s /usr/sessionmanagerplugin/bin/session-manager-plugin /usr/bin/session-manager-plugin
-}
-
-pre_upgrade() {
- pre_install
-}
-
-post_upgrade() {
- post_install
-}
-
-pre_remove() {
- echo "Stopping session-manager-plugin"
- if [ $(cat /proc/1/comm) = init ]
- then
- stop session-manager-plugin || true
- elif [ $(cat /proc/1/comm) = systemd ]
- then
- systemctl stop session-manager-plugin
- systemctl disable session-manager-plugin
- systemctl daemon-reload
- fi
-}
-
-post_remove() {
- if [ -f /usr/bin/session-manager-plugin ]
- then
- rm /usr/bin/session-manager-plugin
- fi
-}