summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSemyon Maryasin2017-11-27 17:18:53 +0300
committerSemyon Maryasin2017-11-27 17:18:53 +0300
commite37b57d19511293bd089058742c7d82499b944c5 (patch)
treeb5ea11c75408de83e3ea5504f1e7d2a9dedfaecd
parentc1790f518634111f9a371f8c2f63af2311207195 (diff)
downloadaur-e37b57d19511293bd089058742c7d82499b944c5.tar.gz
Fix service file location
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db1098fa1a22..fae1a9c95f09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,12 +24,9 @@ noextract=()
md5sums=('ab96cb73e17dffb757d395a0f0ebd6df')
validpgpkeys=()
-prepare() {
- # the rpm we downloaded contains init scripts for both upstart and systemd;
- # but we don't need initctl so let's remove it.
- rm -rf etc/init
-}
-
package() {
- cp -a etc usr $pkgdir/
+ install -Dm 755 usr/bin/xray $pkgdir/usr/bin/
+ # fix target directory: we want system-installed service files to live in /usr/lib, not /etc
+ install -Dm 644 etc/systemd/system/xray.service $pkgdir/usr/lib/systemd/system/
+ install -Dm 644 etc/amazon/xray/cfg.yaml $pkgdir/etc/amazon/xray/
}