summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Hillmann2021-06-26 10:55:34 +0200
committerRichard Hillmann2021-06-26 10:55:34 +0200
commit72a07fa43fc37aa95a8ecb632a7c031bd4b628fd (patch)
tree1cf3a1f8f619c0e8c82a7711d333f7c4d9d3019f
downloadaur-72a07fa43fc37aa95a8ecb632a7c031bd4b628fd.tar.gz
Init 1.0.0 release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--awsvpnclient.install25
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30c6beba1da6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = awsvpnclient
+ pkgdesc = AWS VPN Client
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://aws.amazon.com/vpn/
+ install = awsvpnclient.install
+ arch = x86_64
+ license = custom
+ makedepends = xz
+ options = !strip
+ options = staticlibs
+ source = https://d20adtppz83p9s.cloudfront.net/GTK/1.0.0/awsvpnclient_amd64.deb
+ sha512sums = 07cf41a23b983a98e15719e37d52ce58ad10c0300a8fee03563a6c66b5992b6f148f8075b564f7b254ff230c9772ff692fc248aec45749e11d6b7d076befd880
+
+pkgname = awsvpnclient
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28c06c095858
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Richard Hillmann <richie at project0 dot de>
+pkgname=awsvpnclient
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="AWS VPN Client"
+arch=('x86_64')
+license=('custom')
+url='https://aws.amazon.com/vpn/'
+source=(
+ "https://d20adtppz83p9s.cloudfront.net/GTK/${pkgver}/awsvpnclient_amd64.deb"
+)
+sha512sums=(
+ '07cf41a23b983a98e15719e37d52ce58ad10c0300a8fee03563a6c66b5992b6f148f8075b564f7b254ff230c9772ff692fc248aec45749e11d6b7d076befd880'
+)
+depends=()
+makedepends=('xz')
+options=('!strip' 'staticlibs')
+install='awsvpnclient.install'
+
+package(){
+ tar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+
+ # Permission fix
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ # License
+ install -Dm644 "${pkgdir}/opt/awsvpnclient/Resources/LINUX-LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgdir}/usr/share/doc/awsvpnclient/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/copyright"
+} \ No newline at end of file
diff --git a/awsvpnclient.install b/awsvpnclient.install
new file mode 100644
index 000000000000..9b2907cb3d11
--- /dev/null
+++ b/awsvpnclient.install
@@ -0,0 +1,25 @@
+# https://gitlab.archlinux.org/pacman/pacman/raw/master/proto/proto.install
+service=awsvpnclient
+
+# pre_install() {}
+
+post_install() {
+ systemctl daemon-reload
+ echo "The AWS VPN client requires the service ${service} to be functional"
+ echo "Please enable with 'sudo systemctl enable ${service} && sudo systemctl start ${service}'"
+}
+
+# pre_upgrade() {}
+
+post_upgrade() {
+ systemctl daemon-reload
+ echo "You may need to restart the ${service} service with 'sudo systemctl restart ${service}'"
+ echo "Restarting the service ${service} will interrupt your current connections!"
+}
+
+pre_remove() {
+ systemctl stop awsvpnclient
+ systemctl disable awsvpnclient
+}
+
+# post_remove() {} \ No newline at end of file