summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Hillmann2022-04-19 12:50:26 +0200
committerRichard Hillmann2022-04-19 12:50:26 +0200
commit945c021c3173697ca183e9f63fb19381a6093fdf (patch)
treee69527b625073bc1d78b3ee36a76ba0829a8f2dc
parent44aa608bd382a80498223f7ca258be71e17e42b1 (diff)
downloadaur-945c021c3173697ca183e9f63fb19381a6093fdf.tar.gz
Patch runtime config, fix icu error msg
Seems the binary cannot detect the new ICU package anymore. Fix by disabling localisations in runtime config. > Process terminated. Couldn't find a valid ICU package installed on the system. > Set the configuration flag System.Globalization.Invariant to true if you want to run with no globalization support.
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
-rw-r--r--awsvpnclient.runtimeconfig.json.patch11
4 files changed, 22 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a9de3f8c91a..9c1c3cceb0b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = awsvpnclient
pkgdesc = AWS VPN Client
pkgver = 3.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://aws.amazon.com/vpn/
install = awsvpnclient.install
arch = x86_64
@@ -13,7 +13,9 @@ pkgbase = awsvpnclient
options = staticlibs
source = awsvpnclient-3.0.0.deb::https://d20adtppz83p9s.cloudfront.net/GTK/3.0.0/awsvpnclient_amd64.deb
source = awsvpnclient.desktop.patch
+ source = awsvpnclient.runtimeconfig.json.patch
sha512sums = acbe9a5fd0a04b18effc35993d4809b451e717eb507ff31a5f79355463d80b488e3fbd149ad781396bc3e5182346302932d69e105e6341b60ce167f8c90044ef
sha512sums = 0c32ba0b81ac1123dd6123ee2f4b7573957eab76ae40708e2acfd28b15c9b1717b63450d40bddf449e088b0cf202faac466bd4d7bd79cf2a032735190b625c20
+ sha512sums = 1d45e50de14b9e10b6463692df63bfb4cbedfed952022c95f05bde46ece37ac1a433b76e49f255f38b1bd67c0f0f13d2d8c963051a144553c63149e6041d6603
pkgname = awsvpnclient
diff --git a/.gitignore b/.gitignore
index 98a18eae47b5..0d382b3fafd6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar
+*.tar.*
*.deb
src/
pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index bffb2f011635..b8a8f4ee5e6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Richard Hillmann <richie at project0 dot de>
pkgname=awsvpnclient
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="AWS VPN Client"
arch=('x86_64')
license=('custom')
@@ -9,9 +9,11 @@ url='https://aws.amazon.com/vpn/'
source=(
"$pkgname-$pkgver.deb::https://d20adtppz83p9s.cloudfront.net/GTK/${pkgver}/awsvpnclient_amd64.deb"
'awsvpnclient.desktop.patch'
+ 'awsvpnclient.runtimeconfig.json.patch'
)
sha512sums=('acbe9a5fd0a04b18effc35993d4809b451e717eb507ff31a5f79355463d80b488e3fbd149ad781396bc3e5182346302932d69e105e6341b60ce167f8c90044ef'
- '0c32ba0b81ac1123dd6123ee2f4b7573957eab76ae40708e2acfd28b15c9b1717b63450d40bddf449e088b0cf202faac466bd4d7bd79cf2a032735190b625c20')
+ '0c32ba0b81ac1123dd6123ee2f4b7573957eab76ae40708e2acfd28b15c9b1717b63450d40bddf449e088b0cf202faac466bd4d7bd79cf2a032735190b625c20'
+ '1d45e50de14b9e10b6463692df63bfb4cbedfed952022c95f05bde46ece37ac1a433b76e49f255f38b1bd67c0f0f13d2d8c963051a144553c63149e6041d6603')
depends=('xdg-utils' 'lsof')
makedepends=('xz')
options=('!strip' 'staticlibs')
@@ -23,6 +25,9 @@ package(){
# Apply patch to fix desktop file for KDE
patch -s "${pkgdir}/usr/share/applications/awsvpnclient.desktop" "${srcdir}/awsvpnclient.desktop.patch"
+ # Apply patch for broken ICU detection, no localisation
+ patch -s "${pkgdir}/opt/awsvpnclient/AWS VPN Client.runtimeconfig.json" "${srcdir}/awsvpnclient.runtimeconfig.json.patch"
+
# Workaround for missing compatibility of the SQL library with arch linux:
# Intentionally break the metrics agent,
# it will be unable to laod the dynamic lib and wont start but continue with error message
diff --git a/awsvpnclient.runtimeconfig.json.patch b/awsvpnclient.runtimeconfig.json.patch
new file mode 100644
index 000000000000..f9b2cb695c44
--- /dev/null
+++ b/awsvpnclient.runtimeconfig.json.patch
@@ -0,0 +1,11 @@
+--- "AWS VPN Client.runtimeconfig.json" 2022-04-19 12:43:28.876647215 +0200
++++ "AWS VPN Client.runtimeconfig copy.json" 2022-04-19 12:44:11.735426127 +0200
+@@ -1,5 +1,8 @@
+ {
+ "runtimeOptions": {
++ "configProperties": {
++ "System.Globalization.Invariant": true
++ },
+ "tfm": "netcoreapp3.1",
+ "includedFrameworks": [
+ {