summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author-k2019-10-12 16:06:27 -0700
committer-k2019-10-12 17:15:36 -0700
commit874edd0d21d00cb1d60e49d1c05ad8ae9895e338 (patch)
treefa05c06240e1a315332e156f476628f7775e6928
downloadaur-874edd0d21d00cb1d60e49d1c05ad8ae9895e338.tar.gz
Init
-rw-r--r--.SRCINFO40
-rw-r--r--COPYING21
-rw-r--r--PKGBUILD34
-rw-r--r--axe-qt.desktop12
-rw-r--r--axe256.pngbin0 -> 33913 bytes
-rw-r--r--axecore.install43
6 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b68190466dfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = axecore
+ pkgdesc = Axe Core (AXE) is an open source cryptocurrency.
+ pkgver = 1.4.0.2
+ pkgrel = 1
+ url = https://axerunners.com/
+ arch = x86_64
+ license = MIT
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = binutils
+ makedepends = gcc
+ makedepends = libtool
+ makedepends = make
+ makedepends = pkg-config
+ makedepends = protobuf
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = boost
+ depends = boost-libs
+ depends = miniupnpc
+ depends = openssl
+ depends = qrencode
+ provides = axed
+ provides = axe-qt
+ provides = axe-cli
+ provides = axe-tx
+ source = axe256.png
+ source = axe-qt.desktop
+ source = COPYING
+ source = https://github.com/axerunners/axe/releases/download/v1.4.0.2/axecore-1.4.0.2-x86_64-linux-gnu.tar.gz
+ source = https://github.com/axerunners/axe/releases/download/v1.4.0.2/axecore-1.4.0.2-x86_64-linux-gnu.tar.gz.asc
+ validpgpkeys = A9F09620C26999E08EF8F21238E34B740A0E29B7
+ sha256sums = 06b658f3da983270852b305326042ad563e58aa9ef7fb02002996e8bf6b57130
+ sha256sums = c6971f66cbbc7acb74885d35d5f7a9b42ada9a95e864f9c71e67d6f9e8264900
+ sha256sums = 9277abe7d3462deb49df07221f13643c2aa55ebc10725c0b9d6d82df8dd7b457
+ sha256sums = 10d7acda744c805674e8fcfa7f884442121ba8bb4f45e3b1deca3073a5aec67f
+ sha256sums = SKIP
+
+pkgname = axecore
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..66f290306fef
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,21 @@
+Copyright (c) 2009-2015 Bitcoin Developers
+Copyright (c) 2014-2015 Dash Developers
+Copyright (c) 2018-2019 Axe Developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86c73e466ad4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: charlie137 <slowdive@me.com>
+# Contributor: charlie137 <slowdive@me.com>
+# Based on PKGBUILD from dashcore maintained by pizzaman
+
+pkgname='axecore'
+pkgver=1.4.0.2
+pkgrel=1
+pkgdesc="Axe Core (AXE) is an open source cryptocurrency."
+arch=('x86_64')
+url="https://axerunners.com/"
+license=('MIT')
+depends=('qt5-base' 'boost' 'boost-libs' 'miniupnpc' 'openssl' 'qrencode')
+makedepends=('autoconf' 'automake' 'binutils' 'gcc' 'libtool' 'make' 'pkg-config' 'protobuf' 'qt5-tools')
+provides=('axed' 'axe-qt' 'axe-cli' 'axe-tx')
+source=('axe256.png'
+ 'axe-qt.desktop'
+ 'COPYING'
+ "https://github.com/axerunners/axe/releases/download/v${pkgver}/${pkgname}-${pkgver}-$CARCH-linux-gnu.tar.gz"{,.asc})
+sha256sums=('06b658f3da983270852b305326042ad563e58aa9ef7fb02002996e8bf6b57130'
+ 'c6971f66cbbc7acb74885d35d5f7a9b42ada9a95e864f9c71e67d6f9e8264900'
+ '9277abe7d3462deb49df07221f13643c2aa55ebc10725c0b9d6d82df8dd7b457'
+ '10d7acda744c805674e8fcfa7f884442121ba8bb4f45e3b1deca3073a5aec67f'
+ 'SKIP')
+validpgpkeys=('A9F09620C26999E08EF8F21238E34B740A0E29B7')
+
+package() {
+ install -D -m755 "$srcdir/$pkgname-${pkgver%.*}/bin/axe-qt" "$pkgdir/usr/bin/axe-qt"
+ install -D -m755 "$srcdir/$pkgname-${pkgver%.*}/bin/axed" "$pkgdir/usr/bin/axed"
+ install -D -m755 "$srcdir/$pkgname-${pkgver%.*}/bin/axe-cli" "$pkgdir/usr/bin/axe-cli"
+ install -D -m755 "$srcdir/$pkgname-${pkgver%.*}/bin/axe-tx" "$pkgdir/usr/bin/axe-tx"
+ install -D -m644 "COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "axe256.png" "$pkgdir/usr/share/pixmaps/axe256.png"
+ install -D -m644 "axe-qt.desktop" "$pkgdir/usr/share/applications/axe-qt.desktop"
+}
diff --git a/axe-qt.desktop b/axe-qt.desktop
new file mode 100644
index 000000000000..5c81eff58ce2
--- /dev/null
+++ b/axe-qt.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Axe
+Comment=Axe P2P Cryptocurrency
+Comment[fr]=Axe, monnaie virtuelle cryptographique pair à pair
+Comment[tr]=Axe, eşten eşe kriptografik sanal para birimi
+Exec=axe-qt %u
+Terminal=false
+Type=Application
+Icon=axe256
+MimeType=x-scheme-handler/axe;
+Categories=Office;Finance;
diff --git a/axe256.png b/axe256.png
new file mode 100644
index 000000000000..1939a2c580ff
--- /dev/null
+++ b/axe256.png
Binary files differ
diff --git a/axecore.install b/axecore.install
new file mode 100644
index 000000000000..2a2fae90055d
--- /dev/null
+++ b/axecore.install
@@ -0,0 +1,43 @@
+post_upgrade() {
+ msg2 "If you see a 'No block source available' message in the bottom-left corner of the application, close the application, wait 30 seconds, then relaunch it from Terminal with the command `axe-qt -reindex &disown`";
+};
+
+_msg() {
+ _green "==> ";
+ _white "$@";
+ tput sgr 0;
+};
+
+_msg2() {
+ _blue " -> ";
+ _white "$@";
+ tput sgr 0;
+};
+
+_green() {
+ _color "2" "${1}";
+};
+
+_blue() {
+ _color "4" "${1}";
+};
+
+_white() {
+ _color "7";
+ for line; do
+ echo "${line}" ;
+ done ;
+};
+
+_color() {
+ tput bold;
+ tput setaf "${1}";
+
+ if ! [ "${2}" ]; then
+ return;
+ fi;
+
+ printf "%s" "${2}";
+};
+
+# vim: ts=2 sw=2 et: