summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Reinert2017-01-14 15:01:58 +0100
committerJoakim Reinert2017-01-14 15:04:06 +0100
commiteb6c7a2ac72ce1f41646245be67f6c39f7e39939 (patch)
treeb21fd27ce20db83873cbffff052a3da7bb73d4ce
downloadaur-eb6c7a2ac72ce1f41646245be67f6c39f7e39939.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
-rw-r--r--axoloti.sh8
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63a2714ddec0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sat Jan 14 13:46:41 UTC 2017
+pkgbase = axoloti-git
+ pkgdesc = A workbench to compose and edit sound algorithms and interactions for the axoloti core
+ pkgver = 1.0.11.r59.g7c29b09c
+ pkgrel = 1
+ url = http://www.axoloti.com/
+ arch = x86_64
+ license = GPL
+ makedepends = apache-ant
+ makedepends = libtool
+ makedepends = automake
+ makedepends = autoconf
+ depends = java-runtime=7
+ depends = axoloti-runtime>=1.0
+ provides = axoloti
+ conflicts = axoloti
+ source = git+https://github.com/axoloti/axoloti.git
+ source = axoloti.sh
+ sha512sums = SKIP
+ sha512sums = d3df8647a7adb5df40549fe8f81579df11cbe409527f42101d5a1948102895afbd764ee0b7dfb53f56694aea4ba0b1ffeadee012d7b36a9c032d686e1586a0b3
+
+pkgname = axoloti-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c39acba0a0ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Joakim Reinert <mail+aur@jreinert.com>
+
+_gitname=axoloti
+pkgname=${_gitname}-git
+pkgver=1.0.11.r61.g6a05b1c2
+pkgrel=1
+pkgdesc='A workbench to compose and edit sound algorithms and interactions for the axoloti core'
+arch=(x86_64)
+url="http://www.axoloti.com/"
+license=(GPL)
+depends=('java-runtime=7' 'axoloti-runtime>=1.0')
+makedepends=(apache-ant libtool automake autoconf)
+provides=(axoloti)
+conflicts=(axoloti)
+
+source=('git+https://github.com/axoloti/axoloti.git' 'axoloti.sh')
+
+sha512sums=(
+ SKIP
+ d3df8647a7adb5df40549fe8f81579df11cbe409527f42101d5a1948102895afbd764ee0b7dfb53f56694aea4ba0b1ffeadee012d7b36a9c032d686e1586a0b3
+)
+
+build() {
+ echo '##### building GUI... #####'
+ cd "$srcdir/$_gitname"
+ ant
+}
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ install -Dm644 "$srcdir/$_gitname/platform_linux/49-axoloti.rules" \
+ "$pkgdir/etc/udev/rules.d/49-axoloti.rules"
+ install -Dm644 "$srcdir/$_gitname/dist/Axoloti.jar" \
+ "$pkgdir/usr/share/$_gitname/Axoloti.jar"
+ install -Dm755 "$srcdir/axoloti.sh" "$pkgdir/usr/bin/axoloti"
+ install -Dm644 "$srcdir/$_gitname/license.txt" "$pkgdir/usr/share/licenses/axoloti/license.txt"
+}
diff --git a/axoloti.sh b/axoloti.sh
new file mode 100644
index 000000000000..a519106aba78
--- /dev/null
+++ b/axoloti.sh
@@ -0,0 +1,8 @@
+#!/usr/bin/bash
+
+export axoloti_release=/opt/axoloti-runtime
+export axoloti_runtime=/opt/axoloti-runtime
+export axoloti_firmware=/opt/axoloti-runtime/firmware
+export axoloti_home="${XDG_DATA_HOME:-"$HOME/.local/share/"}/axoloti"
+
+java -jar /usr/share/axoloti/Axoloti.jar "$@" 2>&1 | tee "$axoloti_home/axoloti.log"