summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraquarius2016-05-10 23:10:01 +0300
committeraquarius2016-05-10 23:10:01 +0300
commitdb06fd14208e7569a9ab125820dd501144152d34 (patch)
tree6d21514ffc9132a4bb44eea771ff0df6a9f1cf3d
downloadaur-db06fd14208e7569a9ab125820dd501144152d34.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e72db4c966f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ayam
+ pkgdesc = Ayam is a free 3D modelling environment for the RenderMan interface.
+ pkgver = 1
+ pkgrel = 1
+ url = https://sourceforge.net/projects/ayam/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = coreutils
+ depends = libtiff4
+ source_i686 = https://sourceforge.net/projects/ayam/files/Ayam/1.23/ayam1.23.linux.i386.tar.gz/download
+ md5sums_i686 = 40a1e3eb94faa8e4ec6c9ea41cf8a35b
+ source_x86_64 = https://sourceforge.net/projects/ayam/files/Ayam/1.23/ayam1.23.linux.amd64.tar.gz/download
+ md5sums_x86_64 = 40a1e3eb94faa8e4ec6c9ea41cf8a35b
+
+pkgname = ayam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..318375a913b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=ayam
+pkgver=1
+pkgrel=1
+pkgdesc="Ayam is a free 3D modelling environment for the RenderMan interface."
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/ayam/"
+license=('BSD')
+depends=('libtiff4')
+makedepends=('coreutils')
+conflicts=()
+
+source_i686=(https://sourceforge.net/projects/ayam/files/Ayam/1.23/ayam1.23.linux.i386.tar.gz/download)
+source_x86_64=(https://sourceforge.net/projects/ayam/files/Ayam/1.23/ayam1.23.linux.amd64.tar.gz/download)
+
+md5sums_i686=(40a1e3eb94faa8e4ec6c9ea41cf8a35b)
+md5sums_x86_64=(40a1e3eb94faa8e4ec6c9ea41cf8a35b)
+
+package() {
+ cd "$srcdir/bin"
+
+ make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" sysmenu
+ make DESTDIR="$pkgdir/" desktop
+ make DESTDIR="$pkgdir/" filetype
+
+ export PATH=$PATH:/usr/local/ayam/bin
+ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/ayam/bin/plugins
+} \ No newline at end of file