summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2021-01-28 23:23:57 +0100
committerRobert Tari2021-01-28 23:23:57 +0100
commit4b334b7aa8590169cd2bcdc9b3ced6821d8f89b3 (patch)
treefe0dbe1fe799656950130d887faf03c6d1d00041
downloadaur-4b334b7aa8590169cd2bcdc9b3ced6821d8f89b3.tar.gz
Automatic update via tari.in
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD30
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ccf47a0f19f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ayatana-indicator-keyboard
+ pkgdesc = Ayatana Indicator Keyboard Applet
+ pkgver = 0.7.900
+ pkgrel = 1
+ url = https://github.com/AyatanaIndicators
+ arch = i686
+ arch = x86_64
+ arch = pentium4
+ license = GPL3
+ makedepends = intltool
+ makedepends = cmake
+ makedepends = cmake-extras
+ makedepends = glib2
+ makedepends = libx11
+ makedepends = libxklavier
+ depends = libayatana-indicator
+ depends = systemd
+ depends = glib2
+ depends = libxklavier
+ options = !emptydirs
+ source = https://github.com/AyatanaIndicators/ayatana-indicator-keyboard/archive/0.7.900.tar.gz
+ md5sums = 01c24fa95c25227cc03dd30ebc7f8968
+
+pkgname = ayatana-indicator-keyboard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a180fff1de2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Robert Tari <robert at tari dot in>
+
+pkgname="ayatana-indicator-keyboard"
+pkgver="0.7.900"
+pkgrel="1"
+pkgdesc="Ayatana Indicator Keyboard Applet"
+arch=("i686" "x86_64" "pentium4")
+url="https://github.com/AyatanaIndicators"
+license=("GPL3")
+depends=("libayatana-indicator" "systemd" "glib2" "libxklavier")
+makedepends=("intltool" "cmake" "cmake-extras" "glib2" "libx11" "libxklavier")
+source=("https://github.com/AyatanaIndicators/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=("01c24fa95c25227cc03dd30ebc7f8968")
+options=("!emptydirs")
+
+build()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=lib
+ make
+}
+
+package()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+ make DESTDIR="${pkgdir}" install
+}
+