summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2019-03-08 11:45:45 +0100
committerRobert Tari2019-03-08 11:45:45 +0100
commit26765f2435f6b7723b783185818ccfa61f4a7ae6 (patch)
treec4a93432d799e6d0ad536d755ee3e6b85598b7a7
parent4c1f5be6de1c11ebf4ecb61919e2f53a49b8aaba (diff)
downloadaur-26765f2435f6b7723b783185818ccfa61f4a7ae6.tar.gz
Updated description and dependencies
-rw-r--r--.SRCINFO15
-rw-r--r--0001.fix-testing-option.patch20
-rw-r--r--0002.fix-build.patch12
-rw-r--r--PKGBUILD15
4 files changed, 49 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bba2e924923..4f4748dea611 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = ayatana-indicator-messages
- pkgdesc = indicator that collects messages that need a response
+ pkgdesc = Ayatana Indicator that collects messages that need a response
pkgver = 0.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AyatanaIndicators
arch = i686
arch = x86_64
license = GPL3
makedepends = gobject-introspection
- makedepends = gnome-common
makedepends = gtk-doc
makedepends = intltool
makedepends = accountsservice
+ makedepends = mate-common
makedepends = vala
- makedepends = systemd
- depends = dconf
- depends = libayatana-indicator-gtk3
- depends = accountsservice
depends = glib2
+ depends = accountsservice
depends = hicolor-icon-theme
+ depends = dconf
+ optdepends = mate-ayatana-indicator-applet
+ provides = indicator-messages
+ conflicts = indicator-messages
options = !emptydirs
source = http://releases.ayatana-indicators.org/source/ayatana-indicator-messages/ayatana-indicator-messages-0.6.0.tar.gz
md5sums = b8c38939ade3414741c2a4b0ddbb045a
diff --git a/0001.fix-testing-option.patch b/0001.fix-testing-option.patch
new file mode 100644
index 000000000000..23c1a7e26998
--- /dev/null
+++ b/0001.fix-testing-option.patch
@@ -0,0 +1,20 @@
+diff -ura a/configure.ac b/configure.ac
+--- a/configure.ac 2018-11-16 10:22:41.000000000 +0100
++++ b/configure.ac 2019-03-08 11:27:28.382044600 +0100
+@@ -47,8 +47,6 @@
+
+ PKG_CHECK_MODULES(GIO, gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION)
+
+-PKG_CHECK_MODULES(DBUSTEST, dbustest-1)
+-
+ AC_SUBST(APPLET_CFLAGS)
+ AC_SUBST(APPLET_LIBS)
+
+@@ -86,6 +84,7 @@
+ [enable_tests=${enableval}],
+ [enable_tests=auto])
+ if test "x$enable_tests" != "xno"; then
++ PKG_CHECK_MODULES(DBUSTEST, dbustest-1)
+ m4_include([m4/gtest.m4])
+ CHECK_GTEST
+ AM_PATH_PYTHON(3.0,, [:])
diff --git a/0002.fix-build.patch b/0002.fix-build.patch
new file mode 100644
index 000000000000..7e35cd3a8a3a
--- /dev/null
+++ b/0002.fix-build.patch
@@ -0,0 +1,12 @@
+diff -ura a/configure.ac b/configure.ac
+--- a/configure.ac 2018-11-16 10:22:41.000000000 +0100
++++ b/configure.ac 2019-03-08 11:29:08.194837201 +0100
+@@ -3,7 +3,7 @@
+ AC_PREREQ(2.62)
+
+ AM_CONFIG_HEADER(config.h)
+-AM_INIT_AUTOMAKE(subdir-objects)
++AM_INIT_AUTOMAKE()
+
+ AM_MAINTAINER_MODE
+
diff --git a/PKGBUILD b/PKGBUILD
index 945d699481cd..2c3e445c20f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
pkgname="ayatana-indicator-messages"
pkgver="0.6.0"
-pkgrel="1"
-pkgdesc="indicator that collects messages that need a response"
+pkgrel="2"
+pkgdesc="Ayatana Indicator that collects messages that need a response"
arch=("i686" "x86_64")
url="https://github.com/AyatanaIndicators"
license=("GPL3")
-depends=("dconf" "libayatana-indicator-gtk3" "accountsservice" "glib2" "hicolor-icon-theme")
-makedepends=("gobject-introspection" "gnome-common" "gtk-doc" "intltool" "accountsservice" "vala" "systemd")
+depends=("glib2" "accountsservice" "hicolor-icon-theme" "dconf")
+makedepends=("gobject-introspection" "gtk-doc" "intltool" "accountsservice" "mate-common" "vala")
+optdepends=("mate-ayatana-indicator-applet")
source=("http://releases.ayatana-indicators.org/source/${pkgname}/${pkgname}-${pkgver}.tar.gz")
md5sums=("b8c38939ade3414741c2a4b0ddbb045a")
options=("!emptydirs")
+provides=("indicator-messages")
+conflicts=("indicator-messages")
prepare()
{
cd ${srcdir}/${pkgname}-${pkgver}
- sed -i "s@PKG_CHECK_MODULES(DBUSTEST, dbustest-1)@@" configure.ac
- sed -i "s@AM_INIT_AUTOMAKE(subdir-objects)@AM_INIT_AUTOMAKE()@" configure.ac
+ patch -Np1 -i ../../0001.fix-testing-option.patch
+ patch -Np1 -i ../../0002.fix-build.patch
NOCONFIGURE=1 ./autogen.sh
}