summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2021-11-17 14:15:50 +0100
committerRobert Tari2021-11-17 14:15:50 +0100
commit331f86b7b0af56e8d78ea13454dc821e543cd33f (patch)
treea7a90bdb2169275210728f629718226da0d7f1e8
parentdc44455dbcc58ea417b269505877698de1fb431a (diff)
downloadaur-331f86b7b0af56e8d78ea13454dc821e543cd33f.tar.gz
Automatic update via tari.in
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcb4ac735d81..896ae1397a2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,28 +2,24 @@ pkgbase = ayatana-indicator-messages
pkgdesc = Ayatana Indicator that collects messages that need a response
pkgver = 0.8.2
pkgrel = 1
- url = https://github.com/AyatanaIndicators
+ url = https://github.com/AyatanaIndicators/ayatana-indicator-messages
arch = i686
arch = x86_64
arch = pentium4
license = GPL3
- makedepends = libayatana-indicator
+ makedepends = cmake-extras
+ makedepends = glib2
makedepends = gobject-introspection
makedepends = gtk-doc
makedepends = intltool
- makedepends = accountsservice
- makedepends = mate-common
makedepends = vala
- depends = libayatana-indicator
- depends = glib2
+ makedepends = systemd
depends = accountsservice
depends = hicolor-icon-theme
depends = dconf
provides = indicator-messages
conflicts = indicator-messages
- options = !emptydirs
source = https://github.com/AyatanaIndicators/ayatana-indicator-messages/archive/0.8.2.tar.gz
md5sums = 1c43e8cfe56ad4732984938c3fdd14d7
pkgname = ayatana-indicator-messages
-
diff --git a/PKGBUILD b/PKGBUILD
index 060653618673..238818392beb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,32 +5,26 @@ pkgver="0.8.2"
pkgrel="1"
pkgdesc="Ayatana Indicator that collects messages that need a response"
arch=("i686" "x86_64" "pentium4")
-url="https://github.com/AyatanaIndicators"
+url="https://github.com/AyatanaIndicators/ayatana-indicator-messages"
license=("GPL3")
-depends=("libayatana-indicator" "glib2" "accountsservice" "hicolor-icon-theme" "dconf")
-makedepends=("libayatana-indicator" "gobject-introspection" "gtk-doc" "intltool" "accountsservice" "mate-common" "vala")
+makedepends=("cmake-extras" "glib2" "gobject-introspection" "gtk-doc" "intltool" "vala" "systemd")
+depends=("accountsservice" "hicolor-icon-theme" "dconf")
source=("https://github.com/AyatanaIndicators/${pkgname}/archive/${pkgver}.tar.gz")
md5sums=("1c43e8cfe56ad4732984938c3fdd14d7")
-options=("!emptydirs")
provides=("indicator-messages")
conflicts=("indicator-messages")
-prepare()
-{
- cd ${pkgname}-${pkgver}
- NOCONFIGURE=1 ./autogen.sh
-}
-
build()
{
cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr --libexecdir=/usr/lib --enable-gtk-doc --disable-tests --disable-static
+ mkdir build
+ cd build
+ cmake ..
make
}
package()
{
- cd ${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}/build
make DESTDIR="${pkgdir}" install
- find ${pkgdir}/usr/lib -name *.la -delete
}