summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2019-03-13 08:49:31 +0100
committerRobert Tari2019-03-13 08:49:31 +0100
commit78a6b86f216ed6ea9c1a960da85f5f3d5513e504 (patch)
treecf70020db7874d86ee637d09e9fd89b229dcf6a3
parent26765f2435f6b7723b783185818ccfa61f4a7ae6 (diff)
downloadaur-78a6b86f216ed6ea9c1a960da85f5f3d5513e504.tar.gz
Updated PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f4748dea611..b6b8fae6d229 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ayatana-indicator-messages
pkgdesc = Ayatana Indicator that collects messages that need a response
pkgver = 0.6.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/AyatanaIndicators
arch = i686
arch = x86_64
@@ -21,7 +21,11 @@ pkgbase = ayatana-indicator-messages
conflicts = indicator-messages
options = !emptydirs
source = http://releases.ayatana-indicators.org/source/ayatana-indicator-messages/ayatana-indicator-messages-0.6.0.tar.gz
+ source = 0001.fix-testing-option.patch
+ source = 0002.fix-build.patch
md5sums = b8c38939ade3414741c2a4b0ddbb045a
+ md5sums = 04a69f5f375f33564173083098a07855
+ md5sums = 3fed27ba077bf991a0162c5b3b0d8698
pkgname = ayatana-indicator-messages
diff --git a/PKGBUILD b/PKGBUILD
index 2c3e445c20f9..ae533d849acc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Robert Tari <robert at tari dot in>
+# Contributor: Valentin Huélamo <vhuelamo at gmail dot com>
pkgname="ayatana-indicator-messages"
pkgver="0.6.0"
-pkgrel="2"
+pkgrel="3"
pkgdesc="Ayatana Indicator that collects messages that need a response"
arch=("i686" "x86_64")
url="https://github.com/AyatanaIndicators"
@@ -10,30 +11,30 @@ license=("GPL3")
depends=("glib2" "accountsservice" "hicolor-icon-theme" "dconf")
makedepends=("gobject-introspection" "gtk-doc" "intltool" "accountsservice" "mate-common" "vala")
optdepends=("mate-ayatana-indicator-applet")
-source=("http://releases.ayatana-indicators.org/source/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=("b8c38939ade3414741c2a4b0ddbb045a")
+source=("http://releases.ayatana-indicators.org/source/${pkgname}/${pkgname}-${pkgver}.tar.gz" "0001.fix-testing-option.patch" "0002.fix-build.patch")
+md5sums=("b8c38939ade3414741c2a4b0ddbb045a" "04a69f5f375f33564173083098a07855" "3fed27ba077bf991a0162c5b3b0d8698")
options=("!emptydirs")
provides=("indicator-messages")
conflicts=("indicator-messages")
prepare()
{
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -Np1 -i ../../0001.fix-testing-option.patch
- patch -Np1 -i ../../0002.fix-build.patch
+ cd ${pkgname}-${pkgver}
+ patch -Np1 -i ../0001.fix-testing-option.patch
+ patch -Np1 -i ../0002.fix-build.patch
NOCONFIGURE=1 ./autogen.sh
}
build()
{
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
./configure --prefix=/usr --libexecdir=/usr/lib --enable-gtk-doc --disable-tests --disable-static
make
}
package()
{
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
find ${pkgdir}/usr/lib -name *.la -delete
}