summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2021-11-17 15:07:11 +0100
committerRobert Tari2021-11-17 15:07:11 +0100
commit448f99125b2f0f721f125a2e9d8d19837e0017a1 (patch)
tree2054b9bde3296d6792f1149697eeb8df57dba4b1
parent4c0880f4d520e6828e7b1b4a4fcdd00aa243363a (diff)
downloadaur-448f99125b2f0f721f125a2e9d8d19837e0017a1.tar.gz
Automatic update via tari.in
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 135c840d3191..47de4368117c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,26 +2,18 @@ pkgbase = ayatana-indicator-power
pkgdesc = Ayatana Indicator showing power state
pkgver = 2.1.2
pkgrel = 1
- url = https://github.com/AyatanaIndicators
+ url = https://github.com/AyatanaIndicators/ayatana-indicator-power
arch = i686
arch = x86_64
arch = pentium4
- license = GPL2
license = GPL3
- makedepends = cmake
makedepends = cmake-extras
- makedepends = libnotify
- makedepends = glib2
- makedepends = python
- depends = libayatana-indicator
- depends = upower
+ makedepends = gettext
+ depends = glib2
depends = systemd
+ depends = libayatana-common>=0.9.5
depends = libnotify
- depends = dconf
- optdepends = zenity
- options = !emptydirs
source = https://github.com/AyatanaIndicators/ayatana-indicator-power/archive/2.1.2.tar.gz
md5sums = 929a7065c02983f1b3f9c6d31ccd20f5
pkgname = ayatana-indicator-power
-
diff --git a/PKGBUILD b/PKGBUILD
index 52eb00670c9c..71aa36effdd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,19 @@ pkgver="2.1.2"
pkgrel="1"
pkgdesc="Ayatana Indicator showing power state"
arch=("i686" "x86_64" "pentium4")
-url="https://github.com/AyatanaIndicators"
-license=("GPL2" "GPL3")
-depends=("libayatana-indicator" "upower" "systemd" "libnotify" "dconf")
-makedepends=("cmake" "cmake-extras" "libnotify" "glib2" "python")
-optdepends=("zenity")
+url="https://github.com/AyatanaIndicators/ayatana-indicator-power"
+license=("GPL3")
+makedepends=("cmake-extras" "gettext")
+depends=("glib2" "systemd" "libayatana-common>=0.9.5" "libnotify")
source=("https://github.com/AyatanaIndicators/${pkgname}/archive/${pkgver}.tar.gz")
md5sums=("929a7065c02983f1b3f9c6d31ccd20f5")
-options=("!emptydirs")
build()
{
cd ${pkgname}-${pkgver}
mkdir build
cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=lib -Denable_tests=OFF
+ cmake ..
make
}