summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2019-03-04 14:38:51 +0100
committerRobert Tari2019-03-04 14:38:51 +0100
commit44c26f255f12aee0dd645fd089d1747f39fad61b (patch)
treea53752fb50f40a5f99b9b3f2cf9af692f3e19df6
downloadaur-44c26f255f12aee0dd645fd089d1747f39fad61b.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--0000_remove-testing-and-coverage.patch18
-rw-r--r--0001_enum-in-gschemas-unique.patch28
-rw-r--r--PKGBUILD34
4 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96371be26658
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ayatana-indicator-power
+ pkgdesc = Ayatana Indicator showing power state
+ pkgver = 2.0.93
+ pkgrel = 1
+ url = https://github.com/AyatanaIndicators
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ makedepends = cmake
+ makedepends = cmake-extras
+ makedepends = libnotify
+ makedepends = glib2
+ makedepends = python
+ depends = libayatana-indicator-gtk3
+ depends = upower
+ depends = systemd
+ depends = libnotify
+ depends = dconf
+ options = !emptydirs
+ source = http://releases.ayatana-indicators.org/source/ayatana-indicator-power/ayatana-indicator-power-2.0.93.tar.gz
+ md5sums = 65b1804b1021262a1c064f26d58f46a1
+
+pkgname = ayatana-indicator-power
+
diff --git a/0000_remove-testing-and-coverage.patch b/0000_remove-testing-and-coverage.patch
new file mode 100644
index 000000000000..724ba28b7029
--- /dev/null
+++ b/0000_remove-testing-and-coverage.patch
@@ -0,0 +1,18 @@
+diff -ura a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2018-03-16 15:16:35.000000000 +0100
++++ b/CMakeLists.txt 2019-03-04 14:10:15.170638649 +0100
+@@ -83,14 +83,3 @@
+ add_subdirectory(src)
+ add_subdirectory(data)
+ add_subdirectory(po)
+-
+-
+-# testing & coverage
+-enable_testing ()
+-add_subdirectory(tests)
+-find_package(CoverageReport)
+-ENABLE_COVERAGE_REPORT(
+- TARGETS ${SERVICE_LIB} ${SERVICE_EXEC}
+- TESTS ${COVERAGE_TEST_TARGETS}
+- FILTER /usr/include ${CMAKE_BINARY_DIR}/*
+-)
diff --git a/0001_enum-in-gschemas-unique.patch b/0001_enum-in-gschemas-unique.patch
new file mode 100644
index 000000000000..57b583ec9657
--- /dev/null
+++ b/0001_enum-in-gschemas-unique.patch
@@ -0,0 +1,28 @@
+commit 41bf160d2e1efc5185d2f26431394f3feffa0ce4
+Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
+Date: Mon Mar 19 09:24:52 2018 +0100
+
+ data/org.ayatana.indicator.power.gschema.xml.in: Prepend project namespace to enum id.
+
+ Fixes AyatanaIndicators/ayatana-indicator-power#1.
+
+diff --git a/data/org.ayatana.indicator.power.gschema.xml.in b/data/org.ayatana.indicator.power.gschema.xml.in
+index 872b78e..2119aa9 100644
+--- a/data/org.ayatana.indicator.power.gschema.xml.in
++++ b/data/org.ayatana.indicator.power.gschema.xml.in
+@@ -1,5 +1,5 @@
+ <schemalist>
+- <enum id="icon-policy-enum">
++ <enum id="ayatana-indicator-power-icon-policy-enum">
+ <value nick="present" value="0" />
+ <value nick="charge" value="1" />
+ <value nick="never" value="2" />
+@@ -15,7 +15,7 @@
+ <_summary>Show percentage in Menu Bar</_summary>
+ <_description>Whether or not to show the percentage in the menu bar.</_description>
+ </key>
+- <key enum="icon-policy-enum" name="icon-policy">
++ <key enum="ayatana-indicator-power-icon-policy-enum" name="icon-policy">
+ <default>"present"</default>
+ <_summary>When to show the battery status in the menu bar.</_summary>
+ <_description>Options for when to show battery status. Valid options are "present", "charge", and "never".</_description>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35dcaff25943
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Robert Tari <robert at tari dot in>
+
+pkgname="ayatana-indicator-power"
+pkgver="2.0.93"
+pkgrel="1"
+pkgdesc="Ayatana Indicator showing power state"
+arch=("i686" "x86_64")
+url="https://github.com/AyatanaIndicators"
+license=("GPL2" "GPL3")
+depends=("libayatana-indicator-gtk3" "upower" "systemd" "libnotify" "dconf")
+makedepends=("cmake" "cmake-extras" "libnotify" "glib2" "python")
+source=("http://releases.ayatana-indicators.org/source/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=("65b1804b1021262a1c064f26d58f46a1")
+options=("!emptydirs")
+
+prepare()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np1 -i ../../0000_remove-testing-and-coverage.patch
+ patch -Np1 -i ../../0001_enum-in-gschemas-unique.patch
+}
+
+build()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=lib
+ make
+}
+
+package()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}