summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2019-03-08 12:53:50 +0100
committerRobert Tari2019-03-08 12:53:50 +0100
commit576c0ad366c5685e0fc5672e1236179b5bb987ba (patch)
tree42eb813ae3004e5741d0a4db1333e645a5782bf3
parent44c26f255f12aee0dd645fd089d1747f39fad61b (diff)
downloadaur-576c0ad366c5685e0fc5672e1236179b5bb987ba.tar.gz
Updated dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--0000_remove-testing-and-coverage.patch18
-rw-r--r--0002_add-testing-option.patch34
-rw-r--r--PKGBUILD7
4 files changed, 44 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96371be26658..cc7823d034a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ayatana-indicator-power
pkgdesc = Ayatana Indicator showing power state
pkgver = 2.0.93
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AyatanaIndicators
arch = i686
arch = x86_64
@@ -17,6 +17,11 @@ pkgbase = ayatana-indicator-power
depends = systemd
depends = libnotify
depends = dconf
+ optdepends = mate-ayatana-indicator-applet
+ optdepends = zenity
+ optdepends = powerd
+ optdepends = mate-control-center
+ optdepends = mate-power-manager
options = !emptydirs
source = http://releases.ayatana-indicators.org/source/ayatana-indicator-power/ayatana-indicator-power-2.0.93.tar.gz
md5sums = 65b1804b1021262a1c064f26d58f46a1
diff --git a/0000_remove-testing-and-coverage.patch b/0000_remove-testing-and-coverage.patch
deleted file mode 100644
index 724ba28b7029..000000000000
--- a/0000_remove-testing-and-coverage.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -ura a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2018-03-16 15:16:35.000000000 +0100
-+++ b/CMakeLists.txt 2019-03-04 14:10:15.170638649 +0100
-@@ -83,14 +83,3 @@
- add_subdirectory(src)
- add_subdirectory(data)
- add_subdirectory(po)
--
--
--# testing & coverage
--enable_testing ()
--add_subdirectory(tests)
--find_package(CoverageReport)
--ENABLE_COVERAGE_REPORT(
-- TARGETS ${SERVICE_LIB} ${SERVICE_EXEC}
-- TESTS ${COVERAGE_TEST_TARGETS}
-- FILTER /usr/include ${CMAKE_BINARY_DIR}/*
--)
diff --git a/0002_add-testing-option.patch b/0002_add-testing-option.patch
new file mode 100644
index 000000000000..56c60a191580
--- /dev/null
+++ b/0002_add-testing-option.patch
@@ -0,0 +1,34 @@
+diff -ura a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2018-11-16 09:58:09.000000000 +0100
++++ b/CMakeLists.txt 2019-03-08 12:50:54.181592524 +0100
+@@ -6,6 +6,8 @@
+ set(PROJECT_VERSION "2.0.93")
+ set(PACKAGE ${CMAKE_PROJECT_NAME})
+
++option (enable_tests "Build the package's automatic tests." ON)
++
+ ##
+ ## GNU standard installation directories
+ ##
+@@ -86,11 +88,13 @@
+
+
+ # testing & coverage
+-enable_testing ()
+-add_subdirectory(tests)
+-find_package(CoverageReport)
+-ENABLE_COVERAGE_REPORT(
+- TARGETS ${SERVICE_LIB} ${SERVICE_EXEC}
+- TESTS ${COVERAGE_TEST_TARGETS}
+- FILTER /usr/include ${CMAKE_BINARY_DIR}/*
+-)
++if (${enable_tests})
++ enable_testing ()
++ add_subdirectory(tests)
++ find_package(CoverageReport)
++ ENABLE_COVERAGE_REPORT(
++ TARGETS ${SERVICE_LIB} ${SERVICE_EXEC}
++ TESTS ${COVERAGE_TEST_TARGETS}
++ FILTER /usr/include ${CMAKE_BINARY_DIR}/*
++ )
++endif ()
diff --git a/PKGBUILD b/PKGBUILD
index 35dcaff25943..157281d9a3f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
pkgname="ayatana-indicator-power"
pkgver="2.0.93"
-pkgrel="1"
+pkgrel="2"
pkgdesc="Ayatana Indicator showing power state"
arch=("i686" "x86_64")
url="https://github.com/AyatanaIndicators"
license=("GPL2" "GPL3")
depends=("libayatana-indicator-gtk3" "upower" "systemd" "libnotify" "dconf")
makedepends=("cmake" "cmake-extras" "libnotify" "glib2" "python")
+optdepends=("mate-ayatana-indicator-applet" "zenity" "powerd" "mate-control-center" "mate-power-manager")
source=("http://releases.ayatana-indicators.org/source/${pkgname}/${pkgname}-${pkgver}.tar.gz")
md5sums=("65b1804b1021262a1c064f26d58f46a1")
options=("!emptydirs")
@@ -16,14 +17,14 @@ options=("!emptydirs")
prepare()
{
cd ${srcdir}/${pkgname}-${pkgver}
- patch -Np1 -i ../../0000_remove-testing-and-coverage.patch
patch -Np1 -i ../../0001_enum-in-gschemas-unique.patch
+ patch -Np1 -i ../../0002_add-testing-option.patch
}
build()
{
cd ${srcdir}/${pkgname}-${pkgver}
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=lib
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=lib -Denable_tests=OFF
make
}