summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2020-07-25 14:50:04 +0200
committerRobert Tari2020-07-25 14:50:04 +0200
commitabb35883a3702259d6452e75f56581dc86418c6c (patch)
treec30e240c877a123ce438312aa00a18c92066185f
parentc35be5098b32e62bb733c582f77b1f79f8c23213 (diff)
downloadaur-abb35883a3702259d6452e75f56581dc86418c6c.tar.gz
Updated to 2.0.95
-rw-r--r--.SRCINFO9
-rw-r--r--0002_add-testing-option.patch34
-rw-r--r--PKGBUILD14
3 files changed, 8 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f6587ebee55..99a2009c7695 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = ayatana-indicator-power
pkgdesc = Ayatana Indicator showing power state
- pkgver = 2.0.94
+ pkgver = 2.0.95
pkgrel = 1
url = https://github.com/AyatanaIndicators
arch = i686
arch = x86_64
+ arch = pentium4
license = GPL2
license = GPL3
makedepends = cmake
@@ -22,10 +23,8 @@ pkgbase = ayatana-indicator-power
optdepends = mate-control-center
optdepends = mate-power-manager
options = !emptydirs
- source = https://github.com/AyatanaIndicators/ayatana-indicator-power/archive/2.0.94.tar.gz
- source = 0002_add-testing-option.patch
- md5sums = 6b14508f80d39a535dde366358b748b7
- md5sums = 2fab358cf58bfde470e0b1f00931151b
+ source = https://github.com/AyatanaIndicators/ayatana-indicator-power/archive/2.0.95.tar.gz
+ md5sums = fb07dee2f4b2567d4ab45b0d7075d551
pkgname = ayatana-indicator-power
diff --git a/0002_add-testing-option.patch b/0002_add-testing-option.patch
deleted file mode 100644
index 56c60a191580..000000000000
--- a/0002_add-testing-option.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -ura a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2018-11-16 09:58:09.000000000 +0100
-+++ b/CMakeLists.txt 2019-03-08 12:50:54.181592524 +0100
-@@ -6,6 +6,8 @@
- set(PROJECT_VERSION "2.0.93")
- set(PACKAGE ${CMAKE_PROJECT_NAME})
-
-+option (enable_tests "Build the package's automatic tests." ON)
-+
- ##
- ## GNU standard installation directories
- ##
-@@ -86,11 +88,13 @@
-
-
- # testing & coverage
--enable_testing ()
--add_subdirectory(tests)
--find_package(CoverageReport)
--ENABLE_COVERAGE_REPORT(
-- TARGETS ${SERVICE_LIB} ${SERVICE_EXEC}
-- TESTS ${COVERAGE_TEST_TARGETS}
-- FILTER /usr/include ${CMAKE_BINARY_DIR}/*
--)
-+if (${enable_tests})
-+ enable_testing ()
-+ add_subdirectory(tests)
-+ find_package(CoverageReport)
-+ ENABLE_COVERAGE_REPORT(
-+ TARGETS ${SERVICE_LIB} ${SERVICE_EXEC}
-+ TESTS ${COVERAGE_TEST_TARGETS}
-+ FILTER /usr/include ${CMAKE_BINARY_DIR}/*
-+ )
-+endif ()
diff --git a/PKGBUILD b/PKGBUILD
index 705942e6293c..4dd12fdee84f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,19 @@
# Contributor: Valentin Huélamo <vhuelamo at gmail dot com>
pkgname="ayatana-indicator-power"
-pkgver="2.0.94"
+pkgver="2.0.95"
pkgrel="1"
pkgdesc="Ayatana Indicator showing power state"
-arch=("i686" "x86_64")
+arch=("i686" "x86_64" "pentium4")
url="https://github.com/AyatanaIndicators"
license=("GPL2" "GPL3")
depends=("libayatana-indicator" "upower" "systemd" "libnotify" "dconf")
makedepends=("cmake" "cmake-extras" "libnotify" "glib2" "python")
optdepends=("mate-ayatana-indicator-applet" "zenity" "mate-control-center" "mate-power-manager")
-source=("https://github.com/AyatanaIndicators/${pkgname}/archive/${pkgver}.tar.gz" "0002_add-testing-option.patch")
-md5sums=("6b14508f80d39a535dde366358b748b7" "2fab358cf58bfde470e0b1f00931151b")
+source=("https://github.com/AyatanaIndicators/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=("fb07dee2f4b2567d4ab45b0d7075d551")
options=("!emptydirs")
-prepare()
-{
- cd ${pkgname}-${pkgver}
- patch -Np1 -i ../0002_add-testing-option.patch
-}
-
build()
{
cd ${pkgname}-${pkgver}