summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tari2020-11-08 11:19:16 +0100
committerRobert Tari2020-11-08 11:19:16 +0100
commite48a512601e2b157e55bfb4b29778329d3d47c4e (patch)
treea49daf935a0bb0b17e2eeb5629bf52f222be2874
downloadaur-e48a512601e2b157e55bfb4b29778329d3d47c4e.tar.gz
Automatic update via tari.in
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32c04921ac39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ayatana-settings
+ pkgdesc = Configuration tool for tweaking all Ayatana system indicators
+ pkgver = 20.10.14
+ pkgrel = 1
+ url = https://github.com/AyatanaIndicators/ayatana-settings
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = python-polib
+ depends = gtk3
+ depends = gobject-introspection
+ depends = python-psutil
+ options = !emptydirs
+ source = https://github.com/AyatanaIndicators/ayatana-settings/archive/20.10.14.tar.gz
+ md5sums = 14ee7da6a43912b8b4cea8f9d5f23fe9
+
+pkgname = ayatana-settings
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8baaa555d7c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Author: Robert Tari <robert at tari dot in>
+# Maintainer: Robert Tari <robert at tari dot in>
+
+pkgname="ayatana-settings"
+pkgver="20.10.14"
+pkgrel=1
+pkgdesc="Configuration tool for tweaking all Ayatana system indicators"
+arch=("any")
+url="https://github.com/AyatanaIndicators/ayatana-settings"
+license=("GPL3")
+depends=("gtk3" "gobject-introspection" "python-psutil")
+makedepends=("python-setuptools" "python-polib")
+source=("https://github.com/AyatanaIndicators/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=("14ee7da6a43912b8b4cea8f9d5f23fe9")
+options=("!emptydirs")
+
+build()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+