summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIngo Meyer2022-04-04 13:16:55 +0200
committerIngo Meyer2022-04-04 13:16:55 +0200
commit14df3c8f7ea4a54c1d10f953f7df606ee67ffd1f (patch)
treea0f617e7b2d3a0836a321b0490ca672b7d2198c4
parentc1f54547672636bd2ff037ff2eae2d26883114d8 (diff)
downloadaur-14df3c8f7ea4a54c1d10f953f7df606ee67ffd1f.tar.gz
Improve the `idler_fix` patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--idler_fix.patch11
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6c3439325a1..29432d5b3eb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ayatana-webmail-no-indicator-messages
pkgdesc = Webmail notifications and actions for any desktop without ayatana-indicator-messages dependency
pkgver = 22.2.26
- pkgrel = 4
+ pkgrel = 5
url = https://tari.in/www/software/ayatana-webmail/
install = ayatana-webmail.install
arch = any
@@ -30,6 +30,6 @@ pkgbase = ayatana-webmail-no-indicator-messages
source = idler_fix.patch
md5sums = 98ee497c3d3fa3122524c0f654163bc0
md5sums = eb8721b75b144ab35a8e18bb352799ab
- md5sums = 403d6b204f455d4a7ebe3dbdec8691da
+ md5sums = a52812d8d9a779df06b2adf373a15cd5
pkgname = ayatana-webmail-no-indicator-messages
diff --git a/PKGBUILD b/PKGBUILD
index 36a42a06ba00..88abd342d91e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname="ayatana-webmail-no-indicator-messages"
pkgver="22.2.26"
-pkgrel="4"
+pkgrel="5"
pkgdesc="Webmail notifications and actions for any desktop without ayatana-indicator-messages dependency"
arch=("any")
url="https://tari.in/www/software/ayatana-webmail/"
@@ -18,7 +18,7 @@ source=("ayatana-webmail-${pkgver}.tar.gz::https://github.com/AyatanaIndicators/
"idler_fix.patch")
md5sums=("98ee497c3d3fa3122524c0f654163bc0"
"eb8721b75b144ab35a8e18bb352799ab"
- "403d6b204f455d4a7ebe3dbdec8691da")
+ "a52812d8d9a779df06b2adf373a15cd5")
provides=("ayatana-webmail=${pkgver}")
replaces=("unity-mail")
conflicts=("ayatana-webmail" "unity-mail")
diff --git a/idler_fix.patch b/idler_fix.patch
index 3cdae81e49ec..fdb9f371c1f3 100644
--- a/idler_fix.patch
+++ b/idler_fix.patch
@@ -1,14 +1,17 @@
diff --git a/ayatanawebmail/idler.py b/ayatanawebmail/idler.py
-index 8f956ea..3e852a1 100755
+index 8f956ea..b6b63b4 100755
--- a/ayatanawebmail/idler.py
+++ b/ayatanawebmail/idler.py
-@@ -22,6 +22,9 @@ class Idler(object):
+@@ -22,6 +22,12 @@ class Idler(object):
def stop(self):
+ if self.oConnection.oImap is not None:
-+ # Send a NOOP command to interrupt the IDLE mode and free the blocked thread
-+ self.oConnection.oImap.noop()
++ try:
++ # Send a NOOP command to interrupt the IDLE mode and free the blocked thread
++ self.oConnection.oImap.noop()
++ except:
++ pass
self.oEvent.set()
def join(self):