summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIngo Meyer2022-02-28 13:02:30 +0100
committerIngo Meyer2022-02-28 13:02:30 +0100
commit8a05e4515675ce61d49e725b50607c14e3afce42 (patch)
tree378d7bfb4b32ee761ab737e4709bfd09b86e3e6c
parentfc5e6b68b04d06780304281b02d7a53daafbd29c (diff)
downloadaur-8a05e4515675ce61d49e725b50607c14e3afce42.tar.gz
Add a patch to fix the non-changing status icon (GTK status icon)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--status_icon.patch40
3 files changed, 54 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b760d829ef2..85b7fb46e7c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ayatana-webmail-no-indicator-messages
pkgdesc = Webmail notifications and actions for any desktop without ayatana-indicator-messages dependency
pkgver = 22.2.26
- pkgrel = 1
+ pkgrel = 2
url = https://tari.in/www/software/ayatana-webmail/
install = ayatana-webmail.install
arch = any
@@ -26,6 +26,8 @@ pkgbase = ayatana-webmail-no-indicator-messages
conflicts = unity-mail
replaces = unity-mail
source = ayatana-webmail-22.2.26.tar.gz::https://github.com/AyatanaIndicators/ayatana-webmail/archive/22.2.26.tar.gz
+ source = status_icon.patch
md5sums = 98ee497c3d3fa3122524c0f654163bc0
+ md5sums = eb8721b75b144ab35a8e18bb352799ab
pkgname = ayatana-webmail-no-indicator-messages
diff --git a/PKGBUILD b/PKGBUILD
index 088d10bffd91..153fcb5093bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname="ayatana-webmail-no-indicator-messages"
pkgver="22.2.26"
-pkgrel="1"
+pkgrel="2"
pkgdesc="Webmail notifications and actions for any desktop without ayatana-indicator-messages dependency"
arch=("any")
url="https://tari.in/www/software/ayatana-webmail/"
@@ -13,12 +13,20 @@ depends=("hicolor-icon-theme" "dconf" "gobject-introspection" "desktop-file-util
makedepends=("python-setuptools" "python-polib")
optdepends=("ayatana-indicator-messages: Support for indicator messages")
install="ayatana-webmail.install"
-source=("ayatana-webmail-${pkgver}.tar.gz::https://github.com/AyatanaIndicators/ayatana-webmail/archive/${pkgver}.tar.gz")
-md5sums=("98ee497c3d3fa3122524c0f654163bc0")
+source=("ayatana-webmail-${pkgver}.tar.gz::https://github.com/AyatanaIndicators/ayatana-webmail/archive/${pkgver}.tar.gz"
+ "status_icon.patch")
+md5sums=("98ee497c3d3fa3122524c0f654163bc0"
+ "eb8721b75b144ab35a8e18bb352799ab")
provides=("ayatana-webmail=${pkgver}")
replaces=("unity-mail")
conflicts=("ayatana-webmail" "unity-mail")
+prepare()
+{
+ cd ayatana-webmail-${pkgver}
+ patch -Np1 -i "${srcdir}/status_icon.patch"
+}
+
build()
{
cd ayatana-webmail-${pkgver}
diff --git a/status_icon.patch b/status_icon.patch
new file mode 100644
index 000000000000..abd422377cb5
--- /dev/null
+++ b/status_icon.patch
@@ -0,0 +1,40 @@
+diff --git a/ayatanawebmail/application.py b/ayatanawebmail/application.py
+index 917fb3b..1525801 100755
+--- a/ayatanawebmail/application.py
++++ b/ayatanawebmail/application.py
+@@ -187,8 +187,9 @@ class MessagingMenu(object):
+ gi.require_version('AppIndicator3', '0.1')
+ self.oAppIndicator = importlib.import_module('gi.repository.AppIndicator3')
+
+- self.oIndicator = self.oAppIndicator.Indicator.new(APPNAME, 'ayatanawebmail-messages', self.oAppIndicator.IndicatorCategory.APPLICATION_STATUS)
+- self.oIndicator.set_attention_icon('ayatanawebmail-messages-new')
++ self.oIndicatorIconNoMessages = 'ayatanawebmail-messages'
++ self.oIndicatorIconNewMessages = 'ayatanawebmail-messages-new'
++ self.oIndicator = self.oAppIndicator.Indicator.new(APPNAME, self.oIndicatorIconNoMessages, self.oAppIndicator.IndicatorCategory.APPLICATION_STATUS)
+ self.oIndicator.set_status(self.oAppIndicator.IndicatorStatus.ACTIVE)
+ self.oMenu = Gtk.Menu()
+ self.oMenu.append(Gtk.SeparatorMenuItem())
+@@ -265,6 +266,7 @@ class MessagingMenu(object):
+ self.oMenu.insert(oMenuItem, len(self.oMenu.get_children()) - self.nMenuItems)
+
+ if bDrawAttention:
++ self.oIndicator.set_icon(self.oIndicatorIconNewMessages)
+ self.oIndicator.set_status(self.oAppIndicator.IndicatorStatus.ATTENTION)
+
+ self.oMenuItemClear.set_sensitive(True)
+@@ -287,6 +289,7 @@ class MessagingMenu(object):
+
+ if len(self.oMenu.get_children()) - self.nMenuItems == 0:
+
++ self.oIndicator.set_icon(self.oIndicatorIconNoMessages)
+ self.oIndicator.set_status(self.oAppIndicator.IndicatorStatus.ACTIVE)
+ self.oMenuItemClear.set_sensitive(False)
+
+@@ -332,6 +335,7 @@ class MessagingMenu(object):
+
+ if len(self.oMenu.get_children()) - self.nMenuItems == 0:
+
++ self.oIndicator.set_icon(self.oIndicatorIconNoMessages)
+ self.oIndicator.set_status(self.oAppIndicator.IndicatorStatus.ACTIVE)
+ self.oMenuItemClear.set_sensitive(False)
+