summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Schoon2023-12-23 14:34:28 +0000
committerKevin Schoon2023-12-23 14:34:28 +0000
commit5209078de894b8310162b9709f04955cc85bb22b (patch)
treecab1afe97665226d6ed4fe2d4ccefb75798a5c89
downloadaur-5209078de894b8310162b9709f04955cc85bb22b.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD56
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81c347d23f02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ayllu-git
+ pkgdesc = Ayllu Forge
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://ayllu-forge.org/projects/ayllu
+ arch = x86_64
+ license = AGPL3
+ makedepends = rust
+ makedepends = sqlx-cli
+ makedepends = sassc
+ makedepends = npm
+ makedepends = capnproto
+ depends = git
+ provides = ayllu-git
+ source = ayllu::git+https://ayllu-forge.org/projects/ayllu
+ sha256sums = SKIP
+
+pkgname = ayllu-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..377acc886ca6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+ayllu
+pkg
+src
+*.tar.gz
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1890c47be60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+pkgname=ayllu-git
+_pkgname=ayllu
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="Ayllu Forge"
+arch=("x86_64")
+license=("AGPL3")
+url="https://ayllu-forge.org/projects/ayllu"
+depends=(
+ "git"
+)
+makedepends=(
+ "rust"
+ "sqlx-cli"
+ "sassc"
+ "npm"
+ "capnproto"
+)
+provides=("ayllu-git")
+optdepends=()
+source=(
+ "$_pkgname::git+https://ayllu-forge.org/projects/${_pkgname}"
+)
+
+sha256sums=("SKIP")
+
+build() {
+ cd $_pkgname
+ [[ -f db/state.db ]] && rm db/state.db
+ scripts/init_db_if_missing.sh
+ cargo build --release
+
+ npm install
+ scripts/compile_stylesheets.sh
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 "target/release/ayllu" $pkgdir/usr/bin/ayllu
+ install -Dm644 "LICENSE" $pkgdir/usr/share/licenses/ayllu
+ install -Dm644 "config.example.toml" $pkgdir/etc/ayllu/config.example.toml
+ install -Dm644 "contrib/systemd/system/ayllu.service" $pkgdir/usr/lib/systemd/system/ayllu.service
+ install -Dm644 "contrib/systemd/user/ayllu.service" $pkgdir/usr/lib/systemd/user/ayllu.service
+ install -Dm755 "contrib/hooks/post-commit" $pkgdir/usr/share/ayllu/hooks/post-commit
+ install -Dm755 "contrib/hooks/post-receive" $pkgdir/usr/share/ayllu/hooks/post-receive
+
+ install -Dm644 "themes/default/main.min.css" $pkgdir/usr/share/ayllu/themes/default/main.min.css
+ find themes/default/templates -name '*.html' -exec install -Dm644 {} $pkgdir/usr/share/ayllu/{} \;
+ find themes/default/assets -type f -exec install -Dm644 {} $pkgdir/usr/share/ayllu/{} \;
+
+ install -Dm644 "themes/tokyonight/main.min.css" $pkgdir/usr/share/ayllu/themes/tokyonight/main.min.css
+ find themes/tokyonight/templates -name '*.html' -exec install -Dm644 {} $pkgdir/usr/share/ayllu/{} \;
+
+ install -Dm644 "themes/adwaita/main.min.css" $pkgdir/usr/share/ayllu/themes/adwaita/main.min.css
+ find themes/adwaita/templates -name '*.html' -exec install -Dm644 {} $pkgdir/usr/share/ayllu/{} \;
+}