summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkotontrion2023-10-16 16:26:48 +0200
committerkotontrion2023-10-16 16:26:48 +0200
commit7c9b664a0d220ca3be695eb06ff4be2c3ef87782 (patch)
tree0b531dcd36dbbc5d823601cc90e011987211ded4
parent44f9474b084babc275f058a35d62cb3413b7ae69 (diff)
downloadaur-7c9b664a0d220ca3be695eb06ff4be2c3ef87782.tar.gz
update git submodule and optional dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b762f6654c14..a8dc0b3db509 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aylurs-gtk-shell-git
pkgdesc = Aylurs's Gtk Shell (AGS), An eww inspired gtk widget system.
- pkgver = v1.3.0.r9.g5158079
+ pkgver = v1.4.0.r3.gc7b2607
pkgrel = 1
url = https://github.com/Aylur/ags
arch = x86_64
@@ -16,16 +16,14 @@ pkgbase = aylurs-gtk-shell-git
depends = gtk3
depends = gtk-layer-shell
depends = gobject-introspection
- depends = gnome-bluetooth-3.0
- depends = upower
- depends = networkmanager
- depends = libdbusmenu-gtk3
+ optdepends = gnome-bluetooth-3.0: required for bluetooth service
+ optdepends = upower: required for battery service
+ optdepends = networkmanager: required for network service
+ optdepends = libdbusmenu-gtk3: required for systemtray service
conflicts = aylurs-gtk-shell
source = git+https://github.com/Aylur/ags
- source = git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions#branch=nightly
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = aylurs-gtk-shell-git
diff --git a/PKGBUILD b/PKGBUILD
index 17a694e39127..0c3e78ece257 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: kotontrion <kotontrion@tutanota.de>
pkgname=aylurs-gtk-shell-git
_pkgname=ags
-pkgver=v1.3.0.r9.g5158079
+pkgver=v1.4.0.r3.gc7b2607
pkgrel=1
pkgdesc="Aylurs's Gtk Shell (AGS), An eww inspired gtk widget system."
arch=('x86_64')
url="https://github.com/Aylur/ags"
license=('GPL3')
makedepends=('git' 'meson' 'npm')
-depends=('glib2' 'libpulse' 'glibc' 'typescript' 'gjs' 'gtk3' 'gtk-layer-shell' 'gobject-introspection' 'gnome-bluetooth-3.0' 'upower' 'networkmanager' 'libdbusmenu-gtk3')
+depends=('glib2' 'libpulse' 'glibc' 'typescript' 'gjs' 'gtk3' 'gtk-layer-shell' 'gobject-introspection')
+optdepends=('gnome-bluetooth-3.0: required for bluetooth service'
+ 'upower: required for battery service'
+ 'networkmanager: required for network service'
+ 'libdbusmenu-gtk3: required for systemtray service')
conflicts=('aylurs-gtk-shell')
source=("git+${url}"
- "git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions#branch=nightly"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control")
sha256sums=('SKIP'
- 'SKIP'
'SKIP')
pkgver(){
@@ -25,7 +27,6 @@ pkgver(){
prepare() {
cd $srcdir/$_pkgname
git submodule init
- git config submodule.gi-types.url "$srcdir/gi-typescript-definitions"
git config submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git -c protocol.file.allow=always submodule update
}