summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNandor Magyar2024-02-09 11:07:16 +0100
committerNandor Magyar2024-02-09 11:07:16 +0100
commita8994a011727f26d6d6179d0362db91d2a12785f (patch)
treed665deabe0cc9134933c83643c3dd6d6487ff868
downloadaur-a8994a011727f26d6d6179d0362db91d2a12785f.tar.gz
"initial commit, tired of compiling it each time"
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1723e291852
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = azcopy-bin
+ pkgdesc = A command-line utility that you can use to copy data to and from containers and file shares in Azure Storage accounts.
+ pkgver = 10.23.0
+ pkgrel = 1
+ url = https://github.com/Azure/azure-storage-azcopy
+ arch = x86_64
+ license = MIT
+ provides = azcopy
+ conflicts = azcopy
+ source = https://aka.ms/downloadazcopy-v10-linux
+ sha256sums = 69a72297736edd1afa068efc2ee0704baa819c49d6ca9d1a2950a5fff18b8431
+
+pkgname = azcopy-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f53752c1af6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nandor Magyar < nandor magyar dot it at gmail dot com>
+
+_name=azcopy
+pkgname=azcopy-bin
+pkgver=10.23.0
+pkgrel=1
+pkgdesc="A command-line utility that you can use to copy data to and from containers and file shares in Azure Storage accounts."
+arch=('x86_64')
+url="https://github.com/Azure/azure-storage-azcopy"
+license=('MIT')
+provides=("${_name}")
+conflicts=("${_name}")
+source=("https://aka.ms/downloadazcopy-v10-linux")
+sha256sums=('69a72297736edd1afa068efc2ee0704baa819c49d6ca9d1a2950a5fff18b8431')
+
+package() {
+ install -Dm755 "${_name}_linux_amd64_${pkgver}/${_name}" "$pkgdir"/usr/bin/"${_name}"
+ install -Dm644 "${_name}_linux_amd64_${pkgver}/${_name}" -t "$pkgdir/usr/share/licenses/$pkgname"
+}