summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShusui MOYATANI2016-09-02 04:59:02 +0900
committerShusui MOYATANI2016-09-02 05:04:22 +0900
commit8633903b8c4483ebbe1479d1682753acfc1d7d73 (patch)
treec2a8379ee96aef48dff9d6a9bc5abba050f97c63
downloadaur-8633903b8c4483ebbe1479d1682753acfc1d7d73.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD24
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cc326b7d018
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# 木 9月 1 19:58:13 UTC 2016
+pkgbase = azpainterb
+ pkgdesc = Painting software
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://azsky2.html.xdomain.jp/linux/azpainterb/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = fontconfig
+ depends = freetype2
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libx11
+ depends = libxext
+ depends = libxi
+ depends = zlib
+ source = https://osdn.jp/frs/redir.php?f=/azpainterb/66065/azpainterb-1.0.2.tar.bz2
+ sha1sums = 21a5cf30e6e2ca57a6b24782d0859f2c4864bc4e
+
+pkgname = azpainterb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73a3e4ecec51
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+pkg/
+src/
+download
+*.pkg.tar.xz
+*.tar.bz2
+*.tar.gz
+
+# Created by https://www.gitignore.io/api/vim
+
+### Vim ###
+# swap
+[._]*.s[a-w][a-z]
+[._]s[a-w][a-z]
+# session
+Session.vim
+# temporary
+.netrwhist
+*~
+# auto-generated tag files
+tags
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3226f8f4177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Shusui Moyatani <syusui.s at gmail dot com>
+
+pkgname=azpainterb
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Painting software"
+arch=('i686' 'x86_64')
+url="http://azsky2.html.xdomain.jp/linux/azpainterb/"
+license=('GPL3')
+depends=('fontconfig' 'freetype2' 'libjpeg-turbo' 'libpng' 'libx11' 'libxext' 'libxi' 'zlib')
+source=("https://osdn.jp/frs/redir.php?f=/azpainterb/66065/${pkgname}-${pkgver}.tar.bz2")
+sha1sums=("21a5cf30e6e2ca57a6b24782d0859f2c4864bc4e")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make ${MAKEOPTS}
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install-strip
+ install -m 664 README README_ja COPYING NEWS ChangeLog GPL3 BSD "${pkgdir}/usr/share/${pkgname}/"
+}