summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJamie Magee2018-12-12 17:53:12 +0100
committerJamie Magee2018-12-12 17:53:12 +0100
commite34cdc921b01cf2073414a2a9fec526cb73dcf26 (patch)
tree841eeb1365f9d01d2212e10e748c2bc9ddced17e
downloadaur-e34cdc921b01cf2073414a2a9fec526cb73dcf26.tar.gz
Initial upload: azure-functions-core-tools-bin 2.3.148-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a709ffbed2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = azure-functions-core-tools-bin
+ pkgdesc = Command line tools for Azure Functions
+ pkgver = 2.3.148
+ pkgrel = 1
+ url = https://github.com/Microsoft/azure-functions-core-tools
+ arch = x86_64
+ license = MIT
+ optdepends = dotnet-runtime
+ options = staticlibs
+ source = https://github.com/Azure/azure-functions-core-tools/releases/download/2.3.148/Azure.Functions.Cli.linux-x64.2.3.148.zip
+ sha256sums = e08bcbe722212702d0e30ef6bfb7edfd96d46934822b13d310ca11daec0d1be1
+
+pkgname = azure-functions-core-tools-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0dc61d7bce4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jamie Magee <jamie dot magee at gmail dot com>
+_name=azure-functions-core-tools
+pkgname=$_name-bin
+pkgver=2.3.148
+pkgrel=1
+pkgdesc="Command line tools for Azure Functions"
+arch=('x86_64')
+url="https://github.com/Microsoft/$_name"
+license=('MIT')
+optdepends=('dotnet-runtime') # https://github.com/Azure/azure-functions-core-tools/issues/367
+options=('staticlibs')
+source=("https://github.com/Azure/${_name}/releases/download/${pkgver}/Azure.Functions.Cli.linux-x64.${pkgver}.zip")
+sha256sums=('e08bcbe722212702d0e30ef6bfb7edfd96d46934822b13d310ca11daec0d1be1')
+
+package() {
+ install -dm 755 "${pkgdir}/opt/${_name}/"
+ cp -r "${srcdir}/"* "${pkgdir}/opt/${_name}"
+ install -m 755 "func" "${pkgdir}/opt/${_name}/"
+
+ install -dm 755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${_name}/func" "${pkgdir}/usr/bin/func"
+}