summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Aass Dahlen2021-05-11 23:05:20 +0200
committerWilliam Aass Dahlen2021-05-11 23:11:14 +0200
commitbd958475cc5d58e01c4cec56e9ef61afe963d446 (patch)
treeaa7d6eb109dc4e982463c81714645b0cdbb6bc82
downloadaur-bd958475cc5d58e01c4cec56e9ef61afe963d446.tar.gz
Added package
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD30
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..257d44b3c488
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = azure-kubelogin
+ pkgdesc = A Kubernetes credential (exec) plugin implementing azure authentication
+ pkgver = 0.0.9
+ pkgrel = 1
+ url = https://github.com/Azure/kubelogin
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = git+https://github.com/Azure/kubelogin.git#tag=v0.0.9
+ md5sums = SKIP
+
+pkgname = azure-kubelogin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ce802f73c9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daf15abfc338
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+#Maintainer: William Aass Dahlen <cznk@protonmail.com>
+
+pkgname=azure-kubelogin
+pkgver=0.0.9
+pkgrel=1
+pkgdesc='A Kubernetes credential (exec) plugin implementing azure authentication'
+arch=('x86_64')
+license=('MIT')
+url="https://github.com/Azure/kubelogin"
+makedepends=(
+ "go"
+ "git"
+)
+source=(
+ "git+https://github.com/Azure/kubelogin.git#tag=v$pkgver"
+ )
+
+md5sums=('SKIP')
+
+build(){
+ cd kubelogin
+ make
+}
+
+package(){
+
+ cd kubelogin/bin/linux_amd64/
+ install -Dm755 kubelogin $pkgdir/usr/bin/kubelogin
+
+}