summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Arnott2021-04-08 11:41:59 +0000
committerColin Arnott2021-04-08 11:41:59 +0000
commit82c8a1a7340864777d171cf210286c8fa6dda344 (patch)
tree878cc7cad0cc7138ee0e6daaf7d117799c3fac9e
parente62424fcfa9abc2c4986ecaa41864b80b6993e7f (diff)
downloadaur-azure-vhd-utils-git.tar.gz
r38.44cbada-1
pull, modules, gitignore
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 25 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be427b796c2e..e839795cb8da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,14 @@
-# Generated by mksrcinfo v8
-# Sun Dec 10 05:40:56 UTC 2017
pkgbase = azure-vhd-utils-git
pkgdesc = Azure VHD utilities for Go.
- pkgver = r7.d206e6d
+ pkgver = r38.44cbada
pkgrel = 1
url = https://github.com/Microsoft/azure-vhd-utils
- arch = x86_64
- arch = i686
+ arch = any
license = MIT
makedepends = go
makedepends = git
- provides = azure-vhd-utils
- conflicts = azure-vhd-utils
- options = !strip
- options = !emptydirs
+ source = git+https://github.com/Microsoft/azure-vhd-utils
+ sha512sums = SKIP
pkgname = azure-vhd-utils-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 9d7d734a414e..f47b84a2c51b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,34 @@
# Co-Maintainer: Luca Weiss <WEI16416@spengergasse.at>
pkgname=azure-vhd-utils-git
-pkgver=r7.d206e6d
+pkgver=r38.44cbada
pkgrel=1
pkgdesc="Azure VHD utilities for Go."
-arch=('x86_64' 'i686')
+arch=('any')
url="https://github.com/Microsoft/azure-vhd-utils"
license=('MIT')
makedepends=('go' 'git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-options=('!strip' '!emptydirs')
+source=("git+${url}")
+sha512sums=('SKIP')
pkgver() {
- cd $srcdir/src/$_gourl/
+ cd "${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- export GOPATH="$srcdir"
- go get -fix -v -x ${url#https://}
+build() {
+ cd ${pkgname%-git}
+ go build \
+ -o=vhd \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ .
}
package() {
- install -Dm755 $srcdir/bin/azure-vhd-utils "$pkgdir/usr/bin/vhd"
- install -Dm644 $srcdir/src/${url#https://}/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd ${pkgname%-git}
+ install -Dm755 vhd -t "$pkgdir/usr/bin/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}