summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-04-12 15:49:38 +0200
committerLuca Weiss2016-04-12 15:49:38 +0200
commit1f1bd81080118007f0958b08dd772d0173082719 (patch)
tree5903ecc3877e0c1759e3ddf1c7ffaa7137c4ec0e
parentd3e92cfc6e5929a83488c9d80c74f8860afd7ebb (diff)
downloadaur-1f1bd81080118007f0958b08dd772d0173082719.tar.gz
fix pkgver to use the git rev.no
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caa9f5561445..c9f6fb307888 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Apr 10 19:59:43 UTC 2016
+# Tue Apr 12 13:47:45 UTC 2016
pkgbase = azure-vhd-utils-for-go-git
pkgdesc = Azure VHD utilities for Go.
- pkgver = 2016.04.10
+ pkgver = r21.7db4795
pkgrel = 1
url = https://github.com/Microsoft/azure-vhd-utils-for-go
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 257523d29080..5af356b18d3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=azure-vhd-utils-for-go-git
_pkgname=azure-vhd-utils-for-go
-pkgver=2016.04.10
+pkgver=r21.7db4795
pkgrel=1
pkgdesc="Azure VHD utilities for Go."
arch=('x86_64' 'i686')
@@ -12,6 +12,11 @@ makedepends=('go' 'git')
options=('!strip' '!emptydirs')
_gourl=github.com/Microsoft/azure-vhd-utils-for-go
+pkgver() {
+ cd $srcdir/build/src/$_gourl/
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
export GOPATH="$srcdir/build"
go get -fix -v -x ${_gourl}