summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2020-06-16 19:14:09 -0400
committerWilliam Turner2020-06-16 19:14:09 -0400
commit166543aff84a47ad9e7eda28c6670dbdf6de2417 (patch)
tree97643bc4e4d07cc1224ee6674e1693a058d9fbb1
parente31ef44075e8f4e9cdd4b2bca354279e3b667e84 (diff)
downloadaur-166543aff84a47ad9e7eda28c6670dbdf6de2417.tar.gz
Adjust conflicts and provide notice about azuredatastudio-bin
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
-rw-r--r--azuredatastudio.desktop18
-rw-r--r--azuredatastudio.install10
4 files changed, 43 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cee05a5f3c3c..66ea07d64d0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = azuredatastudio
- pkgdesc = Azure Data Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW (formerly SQL Operations Studio).
+ pkgdesc = Azure Data Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW
pkgver = 1.19.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Microsoft/azuredatastudio
+ install = azuredatastudio.install
arch = x86_64
license = custom: microsoft
makedepends = sed
@@ -18,13 +19,12 @@ pkgbase = azuredatastudio
depends = lsof
depends = nss
optdepends = krb5: Windows authentication support
- provides = sqlops
- conflicts = sqlops
+ conflicts = azuredatastudio-bin
options = staticlibs
- source = azuredatastudio.tar.gz::https://go.microsoft.com/fwlink/?linkid=2132349
- source = https://raw.githubusercontent.com/microsoft/azuredatastudio/1.19.0/resources/linux/code.desktop
+ source = azuredatastudio-1.19.0.tar.gz::https://go.microsoft.com/fwlink/?linkid=2132349
+ source = azuredatastudio.desktop
sha256sums = 7beb42d9d7592ae8725a38b3548b87687f1e8449df13d8ec526ae11e38879c01
- sha256sums = ff4696bdbe8047e0222597831564b78a741dc9597b10a5eca6f901d751c1553e
+ sha256sums = 460ef23631450298409a96c75662428ffc356b666eefbab813e78ef71e346727
pkgname = azuredatastudio
diff --git a/PKGBUILD b/PKGBUILD
index 106a4a0281e9..1f800b493ec0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,21 @@
# Maintainer: William Turner <willtur.will@gmail.com>
pkgname=azuredatastudio
pkgver=1.19.0
-pkgrel=1
-pkgdesc="Azure Data Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW (formerly SQL Operations Studio)."
+pkgrel=2
+pkgdesc="Azure Data Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW"
arch=('x86_64')
url="https://github.com/Microsoft/azuredatastudio"
license=('custom: microsoft')
depends=('curl' 'gcc-libs' 'glibc' 'gnupg' 'gtk3' 'libnotify' 'libsecret' 'libxkbfile' 'libxss' 'lsof' 'nss')
makedepends=('sed')
optdepends=('krb5: Windows authentication support')
-provides=('sqlops')
-conflicts=('sqlops')
+conflicts=('azuredatastudio-bin')
options=('staticlibs')
-source=("$pkgname.tar.gz::https://go.microsoft.com/fwlink/?linkid=2132349"
- "https://raw.githubusercontent.com/microsoft/azuredatastudio/${pkgver}/resources/linux/code.desktop")
+install=$pkgname.install
+source=("$pkgname-$pkgver.tar.gz::https://go.microsoft.com/fwlink/?linkid=2132349"
+ "$pkgname.desktop")
sha256sums=('7beb42d9d7592ae8725a38b3548b87687f1e8449df13d8ec526ae11e38879c01'
- 'ff4696bdbe8047e0222597831564b78a741dc9597b10a5eca6f901d751c1553e')
-
-prepare() {
- sed -i "s|/usr/share/@@NAME@@/@@NAME@@|@@NAME@@|g
- s|@@NAME_SHORT@@|${pkgname}|g
- s|@@NAME_LONG@@|Azure Data Studio|g
- s|@@NAME@@|${pkgname}|g
- s|@@EXEC@@|/opt/${pkgname}/bin/azuredatastudio|g
- s|@@ICON@@|${pkgname}|g
- s|inode/directory;||" code.desktop
-}
+ '460ef23631450298409a96c75662428ffc356b666eefbab813e78ef71e346727')
package() {
install -d "${pkgdir}/opt/${pkgname}"
@@ -34,12 +24,10 @@ package() {
# Symlink the startup script in /usr/bin
install -d "${pkgdir}/usr/bin"
ln -s "/opt/${pkgname}/bin/azuredatastudio" "${pkgdir}/usr/bin/${pkgname}"
- # Also add an alias for the previous name to hopefully not break things too much
- ln -s "/opt/${pkgname}/bin/azuredatastudio" "${pkgdir}/usr/bin/sqlops"
# Add the icon and desktop file
install -D -m644 "azuredatastudio-linux-x64/resources/app/resources/linux/code.png" "${pkgdir}/usr/share/icons/${pkgname}.png"
- install -D -m644 code.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
# Install the license file
install -D -m644 "azuredatastudio-linux-x64/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
diff --git a/azuredatastudio.desktop b/azuredatastudio.desktop
new file mode 100644
index 000000000000..e5e55b23985b
--- /dev/null
+++ b/azuredatastudio.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Name=Azure Data Studio
+Comment=Data Management Tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux.
+GenericName=Text Editor
+Exec=/opt/azuredatastudio/bin/azuredatastudio --no-sandbox --unity-launch %F
+Icon=azuredatastudio
+Type=Application
+StartupNotify=false
+StartupWMClass=azuredatastudio
+Categories=Utility;TextEditor;Development;IDE;
+MimeType=text/plain;
+Actions=new-empty-window;
+Keywords=azuredatastudio;
+
+[Desktop Action new-empty-window]
+Name=New Empty Window
+Exec=/opt/azuredatastudio/bin/azuredatastudio --no-sandbox --new-window %F
+Icon=azuredatastudio
diff --git a/azuredatastudio.install b/azuredatastudio.install
new file mode 100644
index 000000000000..341e4049e482
--- /dev/null
+++ b/azuredatastudio.install
@@ -0,0 +1,10 @@
+#! /bin/bash
+
+post_install() {
+ echo '==> The package azuredatastudio will start building from source at the next release!'
+ echo '==> If you want to keep using the pre-built distribution switch to azuredatastudio-bin'
+}
+
+post_upgrade() {
+ post_install
+}