summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2018-05-25 19:25:49 -0400
committerWilliam Turner2018-05-25 19:25:49 -0400
commitb581b5e97e60a236a956dd7cac340f2c97ca4382 (patch)
tree69791b7f93d50cffa5913295de10a9c5d123602e
parentd1c9ac413efcc7a2d37fd4954a8c5499825235b4 (diff)
downloadaur-b581b5e97e60a236a956dd7cac340f2c97ca4382.tar.gz
Bump to 0.29.3 with fix from grassmonk
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f728ba0b4c7e..d50e00650849 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sqlops
pkgdesc = SQL Operations Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux.
- pkgver = 0.27.3
+ pkgver = 0.29.3
pkgrel = 1
url = https://github.com/Microsoft/sqlopsstudio
arch = x86_64
@@ -22,9 +22,9 @@ pkgbase = sqlops
depends = curl
optdepends = krb5: Windows authentication support
options = staticlibs
- source = https://github.com/Microsoft/sqlopsstudio/releases/download/0.27.4/sqlops-linux-0.27.3.tar.gz
+ source = https://github.com/Microsoft/sqlopsstudio/releases/download/0.29.3/sqlops-linux-0.29.3.tar.gz
source = sqlops.desktop
- sha256sums = 58f7fd774fd76526af01e2671deccdc4bf8c63ef06fb2981bd1069161d97940f
+ sha256sums = 1524033eb1a5f6b12459ec5a9156a974a719195b959a12e6a64fa646a1b6b4d3
sha256sums = b5ad95bef9b56aba179c642e0edac04c32aa8cb3c4c0428cf0257119995e1dc2
pkgname = sqlops
diff --git a/PKGBUILD b/PKGBUILD
index 1f740fa86173..8569f566e97e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: William Turner <willtur.will@gmail.com>
pkgname=sqlops
-pkgver=0.27.3
+pkgver=0.29.3
pkgrel=1
pkgdesc="SQL Operations Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux."
arch=('x86_64')
@@ -9,15 +9,18 @@ license=('custom: microsoft')
depends=('fontconfig' 'libxtst' 'gtk2' 'python' 'cairo' 'alsa-lib' 'nss' 'gcc-libs' 'glibc' 'libxss' 'gconf' 'libxkbfile' 'libunwind' 'libsecret' 'curl')
optdepends=('krb5: Windows authentication support')
options=('staticlibs')
-source=("https://github.com/Microsoft/sqlopsstudio/releases/download/0.27.4/sqlops-linux-${pkgver}.tar.gz"
+source=("https://github.com/Microsoft/sqlopsstudio/releases/download/${pkgver}/sqlops-linux-${pkgver}.tar.gz"
'sqlops.desktop')
-sha256sums=('58f7fd774fd76526af01e2671deccdc4bf8c63ef06fb2981bd1069161d97940f'
+sha256sums=('1524033eb1a5f6b12459ec5a9156a974a719195b959a12e6a64fa646a1b6b4d3'
'b5ad95bef9b56aba179c642e0edac04c32aa8cb3c4c0428cf0257119995e1dc2')
package() {
install -d "${pkgdir}/usr/share/${pkgname}"
cp -r "${srcdir}/sqlops-linux-x64/"* "${pkgdir}/usr/share/${pkgname}"
+ # Symlink the SQL Service package as Unknown to workaround distro detection issues
+ ln -s "./Linux" "${pkgdir}/usr/share/${pkgname}/resources/app/extensions/mssql/sqltoolsservice/Unknown"
+
# Symlink the startup script in /usr/bin
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/${pkgname}/bin/sqlops" "${pkgdir}/usr/bin/sqlops"