summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Grossar2024-02-19 13:48:03 +0100
committerLukas Grossar2024-02-19 13:48:03 +0100
commitb5a70d8e2286a885fb34103ff08b87589512518a (patch)
treee08dc1d47f35d77f94b4ebf1457959275318cefb
downloadaur-b5a70d8e2286a885fb34103ff08b87589512518a.tar.gz
Initial release v1.2.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..757b29dd532c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = azwi-bin
+ pkgdesc = CLI that helps manage Entra ID Workload Identity
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/Azure/azure-workload-identity
+ arch = x86_64
+ license = MIT
+ source = https://github.com/Azure/azure-workload-identity/releases/download/v1.2.0/azwi-v1.2.0-linux-amd64.tar.gz
+ sha256sums = d2ef0f27609b7157595fe62b13c03381a481f833c1e1b6290df560454890d337
+
+pkgname = azwi-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4707e12f08c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Lukas Grossar <lukas.grossar@gmail.com>
+
+pkgname=azwi-bin
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="CLI that helps manage Entra ID Workload Identity"
+arch=('x86_64')
+url="https://github.com/Azure/azure-workload-identity"
+license=('MIT')
+source=("https://github.com/Azure/azure-workload-identity/releases/download/v${pkgver}/azwi-v${pkgver}-linux-amd64.tar.gz")
+sha256sums=('d2ef0f27609b7157595fe62b13c03381a481f833c1e1b6290df560454890d337')
+
+package() {
+ install -Dm 755 "$srcdir/azwi" -t "$pkgdir/usr/bin"
+
+ "$pkgdir/usr/bin/azwi" completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/azwi"
+ "$pkgdir/usr/bin/azwi" completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_azwi"
+ "$pkgdir/usr/bin/azwi" completion fish | install -Dm644 /dev/stdin "$pkgdir/usr/share/fish/vendor_completions.d/azwi.fish"
+}