summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAruFu2021-03-28 10:45:57 +0800
committerAruFu2021-03-28 10:45:57 +0800
commit28ae8e09634c24f70d2e4e8ae546146885af38b1 (patch)
tree0df9bc46b592ec4067f0ae3909612ddc1747ee81
downloadaur-28ae8e09634c24f70d2e4e8ae546146885af38b1.tar.gz
Add b2m to AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d2a09506745
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = b2m
+ pkgdesc = Play bilibili or other videos with mpv
+ pkgver = 0.23.0
+ pkgrel = 1
+ url = https://github.com/snylonue/b2m
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = cargo
+ depends = gcc-libs
+ depends = openssl
+ source = https://github.com/snylonue/b2m/archive/refs/tags/0.23.0.tar.gz
+ sha256sums = 3c0016a8da8ed8dd18910953fe2f4a317b5c02c2bfdf0b069d8a9d89e50e0583
+
+pkgname = b2m
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac5a9b98cc76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: AruFu <mraruuu at gmail.com>
+
+pkgname=b2m
+pkgver=0.23.0
+pkgrel=1
+pkgdesc="Play bilibili or other videos with mpv"
+url="https://github.com/snylonue/b2m"
+license=('MIT')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('gcc-libs' 'openssl')
+makedepends=('cargo')
+source=("https://github.com/snylonue/b2m/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('3c0016a8da8ed8dd18910953fe2f4a317b5c02c2bfdf0b069d8a9d89e50e0583')
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cargo install --no-track --locked --all-features --root "$pkgdir/usr/" --path .
+}